Some Player Label Issues

1. I selected the option in Notation Options -> Condensing -> Inactive Players that says ‘Show rests and omit labels’(!), but in fact there are still player labels in situations like this:

I don’t think this is intended behaviour and it may probably be a bug. I have to select all player labels like this one by one and manually hide them, which brings me to—

2. The ‘Select More’ operation (and the Ctrl+Shift+A shortcut) for player labels don’t work. I have to click on every one of them to hide them. Is this also not normal?

  1. There is still room for improvement on this field and it’s on the team’s backlog.

  2. IIRC select more only works in Write mode, and those labels are only selectable in Engrave mode…

This area of Condensing still needs some refinement. At least for the time being, both of these are expected behaviour, even if they’re not always desirable.

Note that the “Hide rests and label active player” option works in conjunction with the (following) “When hiding rests for inactive players” option and the “Minimum length of range of rests to allow hiding”, and all of these can be overridden locally using Condensing Changes.

Thank you for your quick reply. Select More does work in Engrave mode with noteheads and dynamics as I tested, but it doesn’t work with player labels.

Thanks for your kind reply.

…both of these are expected behaviour…

Then could ‘Show rests and omit labels’ be a naming mistake? It obviously doesn’t reflect the actual behaviour :joy:

It’s not a naming mistake. It works in conjunction with the settings that come after it.

My suspicion is that those settings are not compatible with the music you’ve given Dorico, and as such it cannot hide the rests and omit the labels.

I mean ‘ SHOW rests and omit labels’. It does show rests, but it DOESN’T OMIT the labels. lol

There will be something in the music that means that this setting cannot operate. Dorico can only make one automatic decision per phrase, where a phrase is defined as the stuff between rests. If you want a definitive answer as to why this setting is unable to work here, please upload the project. Alternatively, cut the project down to just those two players from the last rest in Flute 1 to the next rest in Flute 1 (and make sure to include a few notes from the end of Flute 2’s previous phrase and the beginning of Flute 2’s next phrase) and upload that.

OK, first here is the example image in the settings, which doesn’t reflect what Dorico actually does:
image

If that doesn’t make it clear, here’s the project:
staff_label_issue.dorico (532.0 KB)

Thank you for your patience!

Right. Read the explanation under the setting:

It doesn’t apply because the start of the system does not have the two instruments on separate stems; it has them on a single stem.

If I apply some magic (a Condensing Change) to split the two instruments onto separate stems, you’ll see that the option does exactly what it says it does. It won’t work at the start of the next system, though, because Dorico currently always restates who’s playing at the start of a system.

P.S. for the benefit of anyone else that may want to help you troubleshoot in future, please set your Music Fonts to Bravura before uploading to the forum - the vast majority of us do not have the MTF fonts installed.

You are right, apologies. Select more does work in Engrave mode!

Now I understand what it really does, although it’s still a little bit confusing. I think the natural way traditional engravers deal with it is different from what Dorico does. Thank you anyway!