Some Plugins Make My Key Commands Not Work

So anyone know what this is about? Whenever I open certain plugins (namely Altiverb and Positive Grid Bias Amps), as long as it’s window is active (like when I’m editing it), I can no longer control Cubase with my computer keyboard. This includes stopping and starting playback with the spacebar, using the numeric keys to go to markers, or any key commands one can use.

Altiverb is different in that it doesn’t do it unless you open the presets window. Masybe that’s a clue.

The fix, of course, is simple: just click in the arrange window. But it’s annoying none the less and frequently stops workflow.

The OS is the master of the keyboard, not the daw.
So depending on how many active windows/programs you have. They will take ownership of the keyboard depending on OS rules.
Thats why you sometimes lose the daw key command.

But you still have the OS key commands, wich you can use. Thats the fix, if you dont like to use the mouse :wink:
If you are on windows, try alt+tab.

Thanks Reflection, for the reply. But I’m looking for a solution that will make these two plugins (Bias and Altiverb) function the way every other plugin does --which is to not disable the Cubase key commands when their windows are open and active.

Anybody? Steinberg?

you might experiment with toggling the Always-on-Top status of those windows.

If you dont want the plugins to put your keyboard in text mode (thats probly the issue), you should contact the plugin vendors and ask for some tips or updates?

What is text mode?

It’s certainly not supposed to work like that. Is there anything special about those plugins? (old, or bridged 32bit etc)

Open up the notepad window. Not much key command control when your in text mode.

Nope. They’re normal 64bit plugs in every other respect. And they both work flawlessly otherwise. Bias has always had a pretty lame GUI. It uses bitmaps I hear and it take longer to load. But I have other plugins that use bitmap and they don’t disable the key commands.

I don’t know what you base the assumption on, that the plugin invokes that particular thing.

But in any case, it’s the plugin manufacturer who is responsible to code things correctly for their GUI, not Steinberg.

Thats basic Operation system Logic.

Take windows as an example. Who do you think is controlling access to the keyboard? The software you are running inside the operation system or the operation system?

Answer is operation system. Only key commands that are permanent are the once you setup with the operation system. 3rd party programs like cubase are quickly ruled out if they Fall on the priority. Entering text mode like notepad, will rule over some 3rd party software hotkeys. It would be a disaster typing if not the operation system where setting the rules. :wink:

Hope you see and understand the logic. I got teached this at school when we had win 3.11
That is some years/decades ago, but not muched has changed as far as system logic.

And I agree that the best place to ask is the software manufacturer. But you can also enter in to the operation system settings and see if you can change the ruling. Maby block access to the keyboard for the software that is annoying.

Oh no doubt there. I wasn’t trying to blame Steinberg. Just wondering if anyone else here is having this problem and found a workaround.

I hear you… I got nothin’ except maybe toggling always-on-top. What OS are you on? If Windows, and you use Autohotkey, there is the “Window Spy” utility included that might help shed some light on what’s going on.