Sometimes Kontakt does not produce sound

Dear Doricorians,


When Kontakt does not produce sound, I should restart Drico to resolve this problem.
As far as I correctly remember, this occurs with more project files.

My default sound engine is NotePerformer.
When I need other sound libraries, I put manually Kontakt and UVIWorkstation, then connect it manually to the players in Play mode.

Mostly, it works pretty well. However, I experience sometimes Kontakt produces no sound.
There is no other way than restarting Dorico to resolve it.

I would like to know if other users also have had the same problem.

Could you please be more precise? Is only Kontakt not producing sound then, but NotePerformer still does? Or is everything mute. If only Kontakt is not producing sound, then I would first check the Dorico mixer page, to see if no channel is muted. Then I’d check the settings of Kontakt.
Or, during playback on every MIDI command coming in, in the Kontakt window in the left top corner a red “LED” shall blink. If that is flickering, then it is most likely a Kontakt setup issue.

Dear Ulf,

I have encountered the case again. I now know when it occurs:
It occurs when opening Dorico after it had crashed.

  1. Dorico crashes.
  2. Relaunching Dorico.
  3. Dorico asks if I want to recover a file or some files.
  4. selecting a file to be recovered.
  5. Kontakt does not play the note on score, but Kontakt plays a note when clicking notes on the Kontakt’s built-in keyboard.
  6. NotePerformer plays notes on the score.
  7. Saving the file via Save as…, but Kontakt does not play sound from the score.
  8. Closing the project file, then reopening it. Kontakt plays notes on the score.

Could you find a pattern to resolve the problem?

As it seems then, Dorico is crashing with you frequently, is that correct?
It should not in first place, so please create a diagnostics report, which also contains crash dumps, so we can have a look why it is crashing.

Second, no I don’t see a pattern or have a clue what is going on there. If NotePerformer is playing, I’d expect the same for Kontakt.
How about the red “LED” in the left top corner of Kontakt, is that flickering while Dorico is playing back?
That would mean, that Dorico is sending MIDI to Kontakt, and in that case it would be a Kontakt setup problem.

You can download a diagnostics report:
https://www.dropbox.com/s/lmlxy3x18f0v0yo/Dorico%20Diagnostics%20copy.zip?dl=0

I forcefully quitted Dorico while opening Kontakt 6 window. The followings occurred:

  1. Kontakt window is still open, while Dorico is stopped.
  2. I launched Dorico, and the same phenomena occurred,
  3. The red “LED” in the left top corner of Kontakt is not flickering while Dorico is playing back.

About the frequent crashing of Dorico.

I think it is due to my bad behaviours. I often do the followings:

  1. I close the lid of my Macbook Pro, while Dorico is running.
  2. I let the machine sleep while Dorico is running.
  3. I disconnect my audio interface (MOTU UltraLite-mk3 Hybrid), while Dorico is running.

All three are not proper ways to use an application which strongly uses an audio interface.

Probably it would be good, if Dorico releases the audio interface when Dorico does not use Audio Driver for 5 or 10 seconds…

Thanks for the data. There is only one crash file and that is of Dorico itself. If just Dorico crashes, the audio engine will continue runninng, but may get into a funny state when Dorico launches again and tries to connect to it again. For that reason, if Dorico crashes, go into Activity Monitor and also kill the process VSTAudioEngine. Then launch Dorico again which in turn will also launch a new audio engine process. Then I’d expect everything to be fine.

Ok, thanks,
Could the developers implement the process when launching Dorico?
Then the user would not suffer from the problem.

Anyway, I tried the folliowings, In the terminal window:

killall VSTAudioEngine3
killall "VST Audio Engine"
killall "/Applications/Dorico 3.5.app/Contents/Applications/VSTAudioEngine3.app/Contents/MacOS/VSTAudioEngine3"

No 1. returns no error message, but “VST Audio Engine” still runs.

No. 2 and No. 3 returns the following error:

No matching processes belonging to you were found

What is the correct terminal command to quit the process? I would manually run an application script or sh file.

You can use killall VSTAudioEngine3, but it’s correct that you’ll see no output. If you execute the command a second time you’ll be told that no matching process can be found.

If you use Activity Monitor to select the process and Force Quit it, then you’ll see it disappear from the list.

Thank you for your kind answers.

I found a more case which let Dorico crash:

Disconnecting a MIDI device leads Dorico to crash.
Is it intended?

I think it would be good if Dorico releases the audio and MIDI drivers when there is no input from the devices and no output to the devices more than some seconds.
I think then there would be no crash. (of course, I am not sure.)

The following is the diagnostic report after the crash caused by MIDI keyboard disconnection:
https://www.dropbox.com/s/0drm8kkii1y716i/Dorico%20Diagnostics%20copy%202.zip?dl=0

It may not be desirable, but pulling out MIDI equipment is likely to cause problems for any software.

With regard to 1 and 2 of your “bad behaviours”, I close the lid of my MBP while Dorico is running with no problems.

Playing Kontakt in Dorico may not work with libraries that function as self-plays, i.e. the plugin has its own player and/or sequencer (NI Session Guitarist, NI Session Horns, etc.). This happens if the “Ext” button is pressed in Kontakt (host synchronization mode is enabled). Of course, in this case, Kontakt doesn’t know how fast to play, so it is silent. However, it may seem strange that the MIDI note signal is transmitted and the keys on the Kontakt keyboard are pressed. The problem can also occur in other VSTi plug-ins for self-playing: Toontrack EZkeys, EZbass, Ample Sound Guitars, and so on, if such plug-ins have the host synchronization mode set. In such situations, the cause of incorrect playback is a defective Dorico engine, which is not able to transmit tempo control signals to plug-ins. At first I thought that the reason lies in the type of VST2 plug-ins, which include Kontakt, EZkeys, etc., but I did some tests and found out that, for example, HALion (VST3) can’t change its playback according to the Dorico tempo either. As a conclusion: Dorico does not transmit data about the tempo of the song to the plugins (neither in VST2 nor VST3). Perhaps this is the company’s policy, or maybe the developers ’ flaw?.. I don’t know. Let Daniel answer this question. :wink:

:smiley:

However, it would be very great if you could connect a VSTi plug-in self-playing to a chord track, for example, NI Session Guitaris Strummed or EZbass, and much more. More creative searches and wins will open up! Many composers and arrangers would welcome this opportunity with great joy! And Dorico will add a new competitive advantage to its piggy Bank. :slight_smile: