Sound coming only through speakers and not through headphones

Hi!

I use Dorico on a Surface pro 4 with Windows 10. When I plug my headphones to the computer in Dorico the sound still comes from my computers speakers. In any other program, the sound comes through my headphones. I am using the Generic Low Latency ASIO Driver and have no other soundcard hooked up with my computer. I have also double checked that the sample rate for my headphones is the same as in Dorico. From the stereo output dropdown menu I can only find the speakers and not the headphones. If I go to device control panel and choose headphones there, and restart Dorico, I get sound from the headphones but not from my speakers. This last untill my next Dorico session. Upon describing my problems it may seem as the problem is that Dorico does not automatically recognise if I have headphones connected or not, which is a hassle to be dealing with every time I open my computer anew. What can I do to solve this?

If anything is unclear due to shaky english, please let me know.

Åsmund

Launch Dorico, start and stop playback, then open the Sound settings in Windows Settings. At the bottom under “Advanced sound options” click “App volume and device preferences.” Have you specified an Output path for Dorico? Is it set to your speakers? If so, switch it to Default (or your headphones) and see if that fixes your issue.

I in this place I can only find VST audio engine, and not Dorico. Is it the same. On the VST audio engine I have set it to standard. Choosing headphones makes no difference.

If you change the option at the top of the Generic Lower Latency ASIO Driver window concerning exclusive control of your interface, do you find the list of outputs changes? You might also try the ASIO4ALL driver, as that may present a different set of outputs.

The Surface hardware must be a little different to other standard laptops. On my Lenovo ThinkPad the device control panel only presents a combined device, speakers/headphones.
On your Surface you seem to have the speaker ports plus the ports for the headphones and Dorico will not switch automatically.
Also, it looks like the headphones ports are only present if you have actually plugged in the headphones. Dorico has at the moment a little problem in recognizing ports coming and going on the fly, that’s why the hassle with restarting Dorico in order to make the changes visible. With the next update we hope to address this issue.
This won’t help you 100%, since still not automatically sound will come through the headphones upon plugging in the phones, but at least the switching will become much easier.
Sorry to say, but for the moment we have no solution for you right now.

Hi, I know this is an old thread, but I have the very same issue, also using Windows 10 on an HP laptop. I’m using the free version of Doric, which I’ve just recently downloaded to try. (My first such composing program, so I’m unfamiliar wtih the technicalities.) I tried what I understand to have been your suggestions but with no luck. I want to be able to input through my MIDI keyboard without the sound coming through my laptop speakers, but instead through my headphones when plugged in - and the same for playback (as happens with any other app). Did you manage to come up with a solution? Thanks

Welcome to the forum Timmitty,
I don’t have a solution for the automatic switching between headphones and speakers. Is that your problem, or that the headphones don’t turn up as ports in the device control panel?

I’ve discovered that the problem is more that Dorico won’t send sound to my headphones at all (the headphones are working as I can hear system sounds through them). As suggested above, I’ve changed the output to headphones on VSTAudionEngine, but when I test it by playing one of my projects I get just silence on headphones, but not when I switch it back to speakers (I’ve restarted Dorico each time to make sure it’s picked up the change). I’m using an HP laptop with Windows 10

Okay, so please go to Edit > Device Setup and then click Device Control Panel, then another little window appears. In that window, in the lower half, is a list of output ports. Does your headphone turn up in that list?
Also, please create a new project from piano template and enter some arbitrary notes. Then do Help > Create Diagnostics Report and attach the corresponding zip file her
Thanks

Thanks for your help. Only the laptop speaker is shown on the Device Control Panel. The diagnostics report:
Dorico Diagnostics.zip (401.7 KB)

I susbsequently tried the suggestion about deselcting the Driver exclusive control (suggested dsreadbury above July 19) and this did make the headphones appear in the list. But still no sound - and now it won’t let me switch back to the speakers!

UPDATE: I closed Dorico and restarted it, and now I can hear things through the headphones. So my immedite problem is solved and I’m happy with that.

UPDATE 2 (the forum is saying I can’t post any more replies as I’m a new member - and can only edit a previous post. So this is a reply to your post below):
Dorico Diagnostics.zip (395.1 KB)

Just to confirm the sound is now coming through the headphones. Thanks for your help.

Yes all sorted it seems. Thanks very much.

So if you are in the Device Control Panel, in the list of output ports now your headphones do get shown, right? In front of the the label is a little checkbox, you need to tick that in order to activate that port. Then close the Device Control Panel and also the Device Setup dialog.
Under normal circumstances after that the sound shall then come through the headphones.

In the diagnostics you’ve sent, there is no indication of the headphone port, yet. So could you please do as described above and make a new diagnostics report? Thanks

1 Like

So everything is sorted now with you, Tim? No need for further assistance?

1 Like