Sound has stopped working

Yesterday, Dorico sound worked fine. Today: silence. I’ve worked through the sound troubleshooting video at https://www.youtube.com/watch?v=5BcPJd92zqU with no success. I’m on Windows 10, I only have one sound output card connected, and the playhead is moving. Other programs such as YouTube, Spotify and Sibelius sound just fine.

Where do I go from here?

Do you get sound (audition) when you enter a note in note input mode?

Is your sample rate set correctly?

No audition when I enter a note.

Sample rate is set to 48000 - the only option available in the device setup dialog dropdown.

And I’ve tried rebooting, and I’ve tried reinstalling Dorico.

Have you tried resetting the playback template by opening a project that doesn’t sound, and choosing Play > Playback Template, then re-choosing e.g. ‘HSSE+HSO (Pro)’ from the list and clicking OK?

Have you tried using the alternative ASIO4ALL audio driver, in case that works where the Generic Lower-latency Audio Driver is somehow falling over?

I’d tried resetting the playback template. Switching to ASIO4ALL works, though, so it looks like the generic lower-latency audio driver is the issue.

Thanks for getting me back up and running - now is there anything I should do about the generic lower-latency audio driver? Latency shouldn’t be an issue on my current project, but it might be in the future.

If ASIO4All works fine with you, then there is no reason to not use it all the time, so please continue using it.
With the Steinberg Generic driver, I’m sure it is just a driver or Window setting that prevents it from putting sound out, but it’s rather difficult to guide you through, and since the other one is working for you…

On my windows10 box, sound worked fine, but playback just hung. These steps cured it for me:

  1. Power off audio interface
  2. Turn off windows automatic updates (gives a 35-day delay)
  3. Uninstall the last windows cumulative update. The release notes state general audio problems (and a bunch of other unresolved issues). I don’t understand why the released this update.

Start everything back up, and the world is good.

ASIO4ALL doesn’t really work fine with me, because using that I’ve gone back to the problem of not being able to watch youtube videos when Dorico is open, and the instructions to fix that which worked for the Steinberg generic driver don’t work for ASIO4ALL. That’s really frustrating, as much of the documentation on how to use Dorico I can only find on YouTube (try searching Dorico Help for, say, “quantization” or “quantisation”, for example - nothing found) so I have to save my work, exit Dorico, exit the Steinberg Hub, watch the video, open up Dorico again, load my work, realise that I’ve forgotten where the menu is that the video mentioned, shut down Dorico again … grr.

If you have changed both of the exclusive mode settings described in the video (the asio GLL device one, and the Windows system setting), and you can’t play back simultaneously with Dorico + YouTube then this suggests there is either some other exclusive setting for your soundcard or a conflict with the sample rate between the applications. If you can’t get this to work with asio4all either then I would look again at the windows sound device setting. Try changing the sample rate there. Is there an application to control your on board sound device? If so, try looking there to see if you can change the sample rate or disable some of the extra features such as surround sound.

FWIW I use ASIO4ALL on Windows 10 and don’t have audio lockout problems. On my system ASIO4ALL is generally better behaved than the Steinberg generic driver, which doesn’t find some of my Audio devices (I never really investigated why, since ASIO4ALL does find them!) , but I wouldn’t want to generalize from one data point.

The issue is slightly different to what PaulWalmesley describes. The Steinberg ASIO driver has completely stopped giving me any sound at all - nothing to do with YouTube. It’s only when I switch to ASIO4ALL I get the issue with YouTube. And I can’t find the exclusive setting for ASIO4ALL - a Google search suggests it doesn’t have one but is always exclusive, so I’d be interested to know how RobTuley has the system configured.

If you choose the Steinberg Generic Low Latency driver, in the driver panel, what output ports do get listed in there?

In Dorico Preferences / Play / Audio Device, “Suspend audio device in background” is NOT ticked.

My ASIO4ALL is V2.11 beta 2. (V2.11 has now been released, but if beta 2 ain’t broke for me, why upgrade it?)

The ASIO settings are
Buffer size = 1024 samples,
Latency compensation In: 0, Out: 0
Buffer Offset 4ms
None of “Allow Pull Mode (WaveRT)”, “Always Resample 44.1<->48” and “Force WDM driver to 16 Bit” are ticked.
(Not that I know what most of those options do anyway, without reading the manual!)

I just confirmed it works - I can simultaneously play a Dorico score and the audio from a YouTube video, while typing this.

Browser is Internet Explorer 11.

Sorry, but I don’t know what else to tell you beyond that.

Whenever this has happened to me, it’s always been a sample rate mismatch. Just check what sample rate is set in Dorico under Device Setup and then in your Windows sound control panel.

Please post a screenshot of the Generic Low Latency Driver panel. It’s going to get a little tedious, but I’m sure I can get your sound back. Just need a bit back and forth.