Sound in speakers but not in headphones

Hello, everybody!

I’m having an issue that I’m pretty sure I didn’t have before the 2.2 update.
I’ve tried to search this forum and I’ve also watched the troubleshooting video on Youtube, but I can’t figure it out.

Dorico works flawlessly when I’ve chosen the speakers output, but I get no sound in my headphones.

I’ve tried all kinds of combinations of settings, but no luck.
I’ll just attach a few snippets so you can see what settings I’m currently using. (They’re in Norwegian, but you’ll know what you’re seeing)
I’ll also mention that in device setup in Dorico, I only have the 48KHz option, not the 44.1 one that Anthony recommends.

Hope you can help me.

All the best from Jim-Roger Knutsen

Two more snippets.

In the ASIO Device Control Panel, in the middle under Output Ports, it shows that the Speakers are chosen for output. Click on the little checkbox in front of Headphone to make that the output.

Hello, Ulf!

Thank you so much for replying!
It was a poorly chosen snippet, but that’s the thing. That’s what I’ve done, and that’s when I get no sound, neither in the speakers (naturally) nor in the headphones.
I still get sound from other applications such as Internet (Youtube) and Spotify through the headphones.
I’ve also tried allowing the ASIO host application exclusive control (etc.) as well.
Hope you can help me further.

All the best!

Hi Jim-Roger,
I just realized that Dorico has a little problem picking up the new port assignment when switching in the Device Control Panel.

Please do the following:

  • In the Device Control Panel click on the little checkbox in front of Headphone.
  • Then close the Control Panel and also close the Device Setup dialog with ‘OK’.
  • Restart Dorico

Does then sound come from the headphones? If still not, please choose from the Dorico main menu ‘Help > Create Diagnostics Report’.
That creates a zip file on your desktop, please send to ‘u dot stoermer at steinberg dot de’.

Hi, Ulf!

That worked! That’s great!

So presumably, I’ll have to wait for the next patch for this to be fixed, or is there any way I can convince Dorico to catch the port assignment without having to restart, with the current version of the software?

All the best!

Good to hear.

Actually, we don’t have a fix for it, yet, as it just now, that you are reporting this, got to our attention, but I’ll enter it in our bug base.

Instead of restarting Dorico, you could simply change the ASIO driver back and forth, that also helps.
Do you have another driver than the ‘Generic Low Latency Driver’ in the list?
If not, you could download ASIO4All (, which is for free.

Hi, Ulf!

I understand that you don’t have a patch ready, I was just hoping for a quicker work around, which you gave me, so I’m very happy with great help and customer service once again. Thank you!

All the best!

Hello again!

I have another question regarding this.

Long story short: When I open the Device Control Panel for Genereic Low Latency ASIO Driver, I have no option to send sound through the headphones although I do get sound through the headphones when playing from Spotify.

I’ve tried using ASIO4ALL, but then Spotify doesn’t work, and I can’t find a button to disallow the host to take exclusive control of the port.
Any ideas?

All the best from Jim-Roger Knutsen

I think Ulf’s reply from a day or two ago might also help you: make sure that you have the right sample rate chosen for your headphones, otherwise its outputs won’t appear.