Sound is heard when editing MIDI, but not when I press Play

I don’t know what happened but a certain Instrument track has just gone silent. The track is not muted, and the virtual instrument is still loaded onto the track.

When I edit the instrument track’s MIDI data (change velocity of a MIDI note or grab/move a MIDI note around the piano roll) I can hear the instrument being triggered accordingly. But when I press Play to play back the music, the track is completely silent despite there being MIDI data that’s supposed to trigger instrument sounds.

What could cause a track to behave like that?

I’ve had this happen long ago in Cubase.
VERY odd.
If I remember correctly I could usually fix it by creating a new Instrument Track and copying the data across.

A few other people had the issue, also.
The was never any acknowledgement of the issue or fix but it hasn’t happened in ages for me.

Hugh

Found an old post on this, though others they reference appear to be gone.

https://www.steinberg.net/forums/viewtopic.php?f=146&t=68274#p397754

Hugh

Yup, this has happened to me once in a while in both Cubase (since I started with version 8) and also Nuendo 8.

I have had it happen a few times as well in Nuendo 8.0.15. If I deselect the track and then go back to it, the problem goes away.

The problem goes away for me only if I copy the MIDI notes from inside the MIDI clip (it doesn’t work if I copy the MIDI clip itself) and paste it into a new MIDI clip. So it’s clear that the problem is in the MIDI clip and not in the MIDI clip’s data (the MIDI notes contained witin it), the track or the VST instrument.

This happened to me on literally the 1st instrument track of the 1st project I created since I purchased and installed Nuendo 8. Not a great 1st impression of a piece of software that costs $2.000.

I’m having the same problem, only backwards lol. When I select a note in the drum editor (kick, snare, etc) I get no sound. When I play it back however, perfect sound. Any ideas??

This has been an occasional issue for me since switching to Cubase 8 a few years ago. Definitely a bug, and the only workaround is to duplicate the original instrument track and MIDI. I reported it a while back and it’s been mentioned before. It’s not fixed in Cubase 9.5, FYI, either.

Not fixed in Cubase Pro 10 either just happened to me. Grrrrrrrrrrr :angry:

OK, hopefully this helps you guys, this just happened to me.

Highlight the track or data that is highlighted and go to the menu - Edit, Unmute. You can also press Shift-U.

Crazy but Edit, Mute (Shift-M) mutes the track but doesnt make the M toggle button yellow, it just mutes the midi notes I think.

I “muted” the notes by rendering in place with the render setting - Mute Source Track selected. Right after it stopped playing so I knew it was related.

Ok I found out what it was on mine, the track was muted but the yellow M wasn’t showing on the track however the M on the top under Transport menu was yellow so I clicked it and now everything works fine, the reason I didn’t think of trying that is because other instances of the same synth were muted, maybe they were somehow midi connected when I copied the same instance to other tracks.

using the score editor in CB10, sometimes when I cut & paste some notes even though the notes are displayed, they will not sound.

I just came across this most annoying PITA issue as well. I’m running Cubase 10.5 Pro. The VST bass track is a UJAM plugin - very robust! My solution was to select the affected track and mute and unmute it. Now the bass track plays. There’s something incredibly awkward and stupid about that design. Steinberg needs to look at this. By copying the track to a newly loaded VST track it probably unmutes the MIDI by default. I had this happen to HALion 6 tracks too! A royal PITA!!!

edit: sorry I realize this might be an even different issue than this post was about


Mute unmute doesn’t work for me.
Monitor / not Monitor doesn’t work.

My midi in activity is not causing notes to fire, though midi activity registers in the lower right midi input monitor

In the process of trying to figure this out, the piano roll keyboard stopped making notes fire when I use the mouse on it. Super screwed I don’t know what to do.

Notes I enter manually trigger the vsti (exdrummer), and play fine on regular playback
but no midi from outside the box causes notes to fire, same for clicks from the mouse on piano roll keyboard.

Not fixed in Cubase Pro 11 either. Just happened to me. Clearly fine in midi editor and when using the playback icon (draging over measure). However, when playback song, it isn’t playing. How frustrating. I can’t believe all the buggy crap I’ve discovered in one day.

I don’t have a solution but can you see what happens if you turn on ‘input monitor’ on that track ?

Somebody else had a problem not totally dis-similar

I tried the MIDI monitor as an insert for that track. It doesn’t show anything. So it’s like the midi doesn’t exist, but it definitely appears to in the editor - I can click on the notes and they are audible.

So I see the issue now. That midi section within the track was muted. I don’t recall clicking that, but maybe it got set when doing some cycle recording.

2 Likes

I’m very glad to find this thread and your notes on it.

I was just having this problem in Cubase Pro 11.0.20. Specifically, I’d just enabled two instrument tracks (both with instances of Kontakt 6 with Strummed Session Guitarist 2 on them), after having them disabled for some days while working on other parts of my arrangement. But I was getting no sound from the MIDI playback on the newly enabled tracks. Nothing was muted (as far as I could tell anyway). Playing the instruments live worked fine. Selecting a note in Key Editor also made sound, so the connection between the track and the VST instrument was clearly working, even if no sound happened on playback (and the Kontakt keyboard didn’t show any activity on playback, either, so it was an issue of the data not being sent from the clips, not a playback issue within Kontakt or a disconnection at the track level; I’d also tried explicitly muting and unmuting the clips using the Mute tool earlier with no luck).

The suggestion you made regarding selecting the track and using Edit/Unmute was key to getting sound back. However, Edit/Unmute was not available at first, so I had to do Edit/Mute first, then Edit/Unmute. After that, not only did the instrument track I’d selected play back, but the other one that was having the problem did as well – i.e. I didn’t have to do the Edit/Unmute separately to get it back to life.

One possible clue here. It is conceivable I’d muted the two tracks in question prior to disabling them. In particular, I had a deadline on a song demo, so I was trying to get to some stripped down version of the project that I could pitch, and these two tracks weren’t far enough along to include by the deadline, so I disabled them to take their load off the system. I may very well have muted the tracks before doing that to see how the project would sound without them, though. So, maybe the issue (at least for my case?) might be that, if tracks that had been muted when they were disabled got (re-)enabled, the Mute button at the track level does not show up as muted, but somehow the clips on the track are in some muted state, which the Edit/Mute then Edit/Unmute clears. If so, that would clearly be a bug in Cubase.

I’m just glad I was able to restore the tracks to making sound without having to create new instrument tracks and move the clips as that would have been a pain in the context of these specific tracks between tweaks I’d made within Kontakt and the tracks’ being multi-lane to separate out key switches and CCs from the chord data (notes).

Rick

I also have this issue regularely

1 Like