Sound Issue with Steinberg drivers

Hi all,

now i need to type everything again since the Steinberg logged me out while writing that. After logging in there was the new topic page again but without what i wrote.

Problem: Can’t hear myself playing over PC Headphones while using the Steinberg drivers. Monitoing is activated - the one next to “activate recording”.
(Is it even possible to do that? I think it did when i set up everything for the first time.)

Using: Steinberg UR22 MK2 (1 Week old) - Connected to PC via USB
My PC Windows 10 - 1803 (Also testing on a fresh install of Windows 1709)
E-Guitar - Connected to Mic2 + HiZ on
Cubase 9.5 + Updates 64bit - Settings and everything on Default on Notebook.

Always: IN = UR22 MK2 , OUT = PC out green mainboard (rear).
Drivers: * Asio DirectX Full Duplex Driver = Get No Input - but available, Output Working. + Gets this Error: Device could not be opened

  • ASIO4ALL v2 = IN and OUT working. But a cracking noise starts after about 3 mins - so not a solution.
    *Generic Low Latency ASIO Driver = UR22 MK2 not available as input. OUT working.
  • Realtek ASIO = No IN - OUT not tested but there is not even an ASIO settings box - so not using it.
  • Yamaha Steinberg USB Asio = IN working - OUT only UR22 MK2 available.

Cubase(Everything) + Steinberg Drivers + Mainboard Audio Drivers + ASIO4All v2 already reinstalled.

There is also humming in the Background when using the ASIO4all driver. Same in Reaper but it’s quieter (Same flaws like in Cubase with the drivers).
Couldn’t test the other ones since i get no input and export is not working. (Literally only worked once to FLAC - now everything I export is empty, checked with Audacity - That would be another problem i’ve got right now).

The only way i got it to work (which isn’t a solution): set up everything like descripted above with Steinberg drivers and conncet a 6,35->3,5 from the “phones jack” on the UR22 mk2 to my “Line In” on pc. Humming persists but there is a strong cracking noise whenever i move my mouse or my CPU load goes over ~12% (Intel i7700k).

Youtube video tutorial didn’t help where everything works as soons as you connect it.

Thx in advance.

Hi and welcome,

You can use only one ASIO driver at given time. So you can’t use UR22 as input and another device as an output.

Plug your headphones to the UR22 headphones output, please.

Thx for the answer.
But what about the other Drivers?
Is it normal that the "Generic Low Latency ASIO Driver " doesn’t show the UR22 as Input?
And when switching to the “Asio DirectX Full Duplex Driver” reports this error : FF9-5-0044 [800004005] - Device could not be opened.

No I’ve got another problem. When using the Steinberg Drivers i get this output (Cubase constant creak and Reaper kinda loops):
Cubase ->
Reaper ->

ASIO4all driver work as always with the cracking after time.

I didn’t change anything - apllied the patch from today and reinstalled again every audio driver but that didn’t help. Could it be that this unit is faulty?

Generic Low Latency is using the system selected Audi Device, if I’m right.

I don’t know, why the Asio FullDuplex through the error.

The cracking is mostly caused by low Buffer Size (latency) value. Increase it, please.

Of course might be the unit is faulty.

Going with Steinberg Drivers now and output from the UR22 mk2 - Thx for your help.

The cracking noise for ASIO4all still persists but is no problem anymore.

But now i get a really annoying humming/buzz from the UR22 MK2.

It’s not a constant one buzz. + It’s way louder with the HIz enabled (which i need for the guitar).

Sec 0 - 5: doing nothing.
Sec 5 - 10: Changing volume on Guitar
Sec 10 - 15: Changing Gate on UR22 (persists on min - turn all to the left and gets pretty loud when turning to the right)

It disappears when i unplug the cable from the UR22 but not completely when i unplug the guitar and leave the cable connected (Cable is as new as the guitar). It’s almost as loud as the guitar when playing.

Red online that this would be a 60/50hz humm (correct me if i’m wrong) and i could solve it by unplugging everything all other devices, but that didn’t help.I have 1 sockets distributors from the power socket and only the PC and Monitor connected. Already tried different USB Ports (+ other USB cables), unplugging everything and changing buffer size.

Hi from Australia,
Have just upgraded to Cubase Elements 9.5 on Windows 10. Older version used to let me run Audacity in the background to create MP3s etc, but as soon as I click off the Cubase window, Audacity stops in its tracks! Audacity works with all my other apps - Finale, Windows Media Player etc. Have changed Audacity to 48,000Hz to agree with Cubase - same result. Have enabled Cubase’s “Release driver when application is in background” - same result.
Anyone have this problem and knows a fix?


Use ASIO driver in Cubase and different driver type in Audacity.

Thanks Martin, still no joy but I will keep tinkering.