Sound lag when recording live MIDI input - but NO sound lag when just inputting notes

Hello there!
I am experiencing a weird problem when I use my MIDI keyboard for recording note input, and I haven’t found any solution in the forums…

My problem:
There is no sound lag at all when I select an instrument in a project and just play on the keyboard. And no lag when inputting notes without live recording. But as soon as I press record and start playing along with the metronome, the sound is more or less exactly one second behind the beat (2 beats in 120 bpm). However, when I stop the recording the played notes are notated correctly…

In other words: everything works as long as I don’t listen to what I am playing… :wink:

I am on Dorico 4.3 and I am running on Mac Os 14.1.1. My MIDI-keyboard is an AKAI LPK25.

Many thanks in advance for any help!

Emil

Welcome to the forum, Emil. Are you using NotePerformer as your playback device? If so, can you try using one of the factory default playback templates to see if this makes any difference?

Hi, thank you!
I’m using NotePerformer, but I have also tried HSSE (Elements), HSSE (SE) and HSSE+HSO (Pro). And there is no difference unfortunately…

Sorry also for a late reply! :slight_smile:

Thanks for the reply, Emil. I assume your keyboard is connected via USB, and not a wireless or Bluetooth connection?

What buffer size setting do you have in Edit > Device Setup? If you have that set to a very high value, you might try reducing it a bit. You should also try the procedure described here:

Hello again,

Thanks you. I have tried the following

  • Every buffer size available (from 32-1024). With no effect.

  • Changing MIDI latency compensation value to -100, -50, 0, +50, +100. This changed the notated notes relative to the beat, but the sound remains late.

Also, today the sound is also delayed when I’m just playing the keyboard without recording… Hm…

If it helps I am using Bluetooth headphones (Jabra Elite 7 Pro). Could that be the issue? I will try to use plug-in headphones later today or tomorrow and see if that has any effect.

Certainly Bluetooth headphones will have higher latency than wired ones, but the latency should be constant for everything that Dorico is playing back, whether it’s coming from playback, echoing notes played when you’re not recording, or echoing notes played during recording.

Hello again.
Apologies for the very long delay in my reply; I had a change in my schedule, and have not been able to try anything regarding my issue until today.
Unfortunately nothing has changed for me when I tried today with plug-in headphones.
Just to recap:

  1. When I hit playback the notes sounds in perfect timing with the “caret” (playhead?) that travels along the music.
  2. When I play on my MIDI Keyboard without recording the notes sound exactly when I play them (no latency).
  3. When I record, the notes sounds at least a second later than I press the keyboard. But they end up notated at the right places in the score when I stop recording.
  4. I have tried everything setting in the buffer size value in my audio device setup, and many different settings for the MIDI latency compensation values (-100, -50,

If I understand you correctly then this sound latency should not be happening? Any other ideas that might help? :slight_smile:

Thank you very much for your patience! :slight_smile:

All the best,
Emil

The weirdest thing happened: I just clicked “Reset to factory”, restarted Dorico and now it works!!!
I did try this the first time around with no success and now, all of a sudden, it works. I just hope it stays like this… :slight_smile:

Thank you again. :slight_smile:

Best,
Emil

…and now it does not work again… :frowning:

What buffer size are you using in Edit > Device Setup? You’re absolutely certain that the same problem occurs when using one of Dorico’s factory playback templates, i.e. not using NotePerformer (though of course it should be fine with NotePerformer as well).

I have tried today 64, 256, 512 and 1024. It is a significant lag (both recording and not recording) at 1024 but none at all at 64 (not recording).

And yes, the problem occurs with Noteperformer and all the three HSSE-options…
It’s just so weird!

Maybe Turn off MIDI Thru? It sounds like when you record MIDI, there’s a ‘feedback’ loop, with the MIDI data going round and round.

Hi! I’ve tried turning of MIDI thru as well, but then I get no sound at all I’m afraid…

I’m afraid I’ve no idea what to suggest. Perhaps @Ulf has some further ideas.

If you go to the Dorico Preferences dialog, choose the Play tab and scroll all the way down to the Advanced Options and unfold them, is ASIO-Guard enabled with you? How does Dorico behave if you toggle that value (and restart Dorico)?

Hi Ulf,
Thanks for your tip!
I tried now and it seems to work. However I also tried before switching off ASIO-Guard, and then it worked as well…
It seems like it’s a problem that comes and goes, but I hope it will remain fixed after I disabled ASIO-guard.
Thank you all for your help!

Let us know should the problem come back again, then we take a deeper look.

Will do! Thanks! :slight_smile: