Sound quality issue with MIDI-USB connection

Hello everyone,

I am having some difficulties with the quality of the sound output when I connect my Yamaha MX61 to my computer on Cubase.

When the MX61 is not connected to the computer, the sound heard in the headphones is excellent. But as soon as I connect it to the computer with the MIDI-USB cable, there is an immediate and noticeable shift of quality: the sound is more echoic. It puzzles me because it has never been the case before, and I have no clue what could have changed since the last use. I have tried updating the drivers, but this did not give any satisfying results.

I am a very basic user of Cubase, with little if no knowledge of music production, so I am aware my question might not seem very accurate but I hope it is enough to find help.

Thank you very much,


Hi and welcome to the forum,

My expectation is, this happens once you record the track and the MIDI track’s output is routed to the Yamaha synth.

If this is the case then switch the Local Control Off on Yamaha. When this is switched On, you send the MIDI data from the keyboard to the synth and also to Cubase and thru Cubase back to the synth. So you send it twice to the synth.

By Local Control Off you disable the keyboard > synth routing. The MIDI data will go to Cubase (only) and then to the MIDI Out you select (I.e. Yamaha it other synth or virtual instrument, …).

Other option would be to TURN OFF MIDI THRU in Cubase and leave Local=ON on the Yamaha.

You have to do one of the TWO options given via Martin or myself to eliminate the midi ECHO you are getting

1 Like

Also, if you are monitoring your AUDIO THRU Cubase via the USB connection and you have the MONITOR button on the track turned on, you WILL have increased audio echo as you say when your audio buffer is set to a higher setting.

Thanks both of you for your swift reply !
I have tried both options but none of them has worked so far unfortunately.
But I made a mistake in my original question: the cable is not connected to the MIDI output of the MX61 but to the USB output. Maybe this changes the problem ?

Also, maybe I am not describing the shift in sound well enough : there is not a clear echo but it sounds somewhat more resonant, or more bright (not sure I am using the right terms here, but this is how I feel it).

What is your AUDIO buffer set to?

Yes I get you are using the USB connection.


Is there Loop back involved in the ASIO driver maybe?

That could be it

Here are the settings of the USB ASIO

How do I check wether there is a loop back ?


I would try the 1st tab, as it is shown at this screenshot.

Unfortunately, the option is not available

Lower your buffer size and see what it does.

You may want to look at the ASIO Guard settings as well in Cubase.

sorry for the late reply. I have tried lowering the buffer size: the quality of sound does indeed vary but it is still a different quality than from the MX61 itself.
But I have noticed something that could help. The shift in quality happens only with my last project. If I open any brand new or previous projects, there is absolutely no shift in quality, it is the exact sound from the MX61. I must have changed some settings in this project without noticing. Do you have any idea what could this be ?

Thanks for your time anyway, it is really helpfull.

If you give me 10 minutes I can probably come up with 150 different things it could be based on the description.
If I were you, I would forget about that one, wonky sounding project and move on.
What you can do, is create a new, fresh project, make sure the sound quality is as expected and then use import the track from the “weird sounding” project.