Sound stopped working after unticking exclusive control

Hi
Dorico was previously working fine with sound as normal on PC. I found that Dorico had taken exclusive access of the internal soundcard as other windows sounds were not playing. On going into preferences and unticking “take exclusive control,” Dorico is now not making any sound. I’ve tried; re-ticking to initialise the ASIO driver, ticking release on background and even tried several restarts to no avail. Any thoughts?

Thanks
Tony

Could you please zip up the folder C:\Users<yourname>\AppData\Roaming\Steinberg\VSTAudioEngine_64 and post here? Also, create a simple Piano project with a handful of bars and arbitrary notes. Please also zip that up and post here. And a screenshot of the driver panel could also be useful.

I finally just let Dorico take complete control while I was using it, so long as it releases control when I close the program. The consistency/predictability was worth the occasional inconvenience. I just had to remember than other programs would not make sounds while Dorico was open.

Here’s the VST folder
VSTAudioEngine_64 - Copy.7z (167 KB)

And here’s a Dorico project

You need to zip up the Dorico project, otherwise you can’t attach it…

Apparently the file is to big at 2.1mb to upload?!

Otherthings I’ve tried is

  • Uninstall Dorico and re-install. Still no sound (although we haven’t tried re-installing Halion etc)
  • ASIO4ALL installed and tried. Still no sound.
  • External sound card. Still no sound. (Soundcard was using both the generic asio drivers installed by steinberg and ASIO4ALL)

However (see pic), levels are moving within the mixer window?!
IMAG0623.jpg

Then please upload to my ftp server:
site: ftp://ustoermer.steinberg.de
user: adler
pass: 040210350

That the mixer is showing levels is a good sign, at least then we know that the engine itself is running and processing audio. Then it is only a matter of getting this finally out to your sound device…

Your project data will give me (hopefully) a further clue.

Sorry for the delay. Uploaded a piece called “layered piece”

Hi Tony,

thanks for the upload. Having a look at the data, I now have a clearer understanding.

We have a known issue where under certain circumstances the port mapping information does get lost, i.e. the audio engine processes all the audio but at the end doesn’t know, to which device port to send it, thus no sound.
That this info is getting lost is actually not so uncommon and not the problem as such. The bug is, that once this port mapping is lost, the user has no means of getting this corrected again, so that particular project will always stay dumb.
We had several similar user reports in the past but at first couldn’t get grip on the issue. It is just happened that since yesterday we now finally exactly understand why it happens and what is going on (and of course are working on a fix.)

So I do see that you don’t get any sound out on the project that you uploaded, but how about if you create a new project? I would expect that it does sound?
If not, what is your current driver setting? ASIO4All or Generic Low Latency Driver (GLLD)? In either case, please make sure that at if you open the Device Control Panel, that an output port is active and selected. In case of GLLD you might not get the built-in sound-chip ports listed unless you tick “Allow ASIO host application to take exclusive control…”
If you still don’t get sound out, please post screenshots of the Device Control Panel.

In regards to the the project you uploaded, do you want to continue working on it? I could apply some magic to it and heal it to 99%. You want that?

Cheers,
Ulf

Hi,

We did create a new project, but it didn’t sound either. We’ve rebuilt the machine so it’s working as usual now (we’re in a school so it was scheduled anyway)

If you could “heal” the file, that would be very good!

Thanks

Sure I can do that. The only thing is, could you upload that project to my ftp site again?
Because it was already some time ago and you didn’t answer anymore, so I thought it was of no interest anymore and deleted it.

Hi,

Sorry. I have re-uploaded. The file is called “layered piece”. I’ve also uploaded another project called “BROOKE comp” which was mentioned in another thread.

Thanks
Tony

Hi Tony,

done. I’ve uploaded the projects into the folder ForTonyMorton.
You now need to load the projects, go to Play Mode, choose Play > Apply Default Playback Template and then save again. Sound shall come out again…

Cheers,
Ulf