Sounds are gone thanks to... well, you tell me

I stumbled upon this video, where the author reports a buggy behaviour:

I tried to replicate it and get the effect that For the first run through all sounds are played back but upon the cycle putting the playhead back to the L-Locator position all sounds of the instruments stop.

I would like to invite you guys to run the attached project on your machine and check the behaviour.
On my machine the two Retrologues indicate that they receive events (orange light) but their keyboards indicate that they don’t play anything.

You need to have the soundbank Analog Techno installed. I hope GA5SE will find the sample automatically.
Cycle_looses_sound.cpr (509.5 KB)

I would like to renew my invitation to check out the attached project and report if you also loose sound.


Maybe nobody likes to counter-check because I haven’t put down much of a description in written form.

Some VST synths can send MIDI, like Groove Agent. Each instance of GA will create a possible MIDI input for MIDI tracks/Instrument tracks. Therefore you are able to send MIDI from GA to any other VST synth.

The project is setup to send MIDI data through GA5SE to two tracks, both using Retrologue (as a simple stock plugin).
Furthermore you will see two MIDI Monitors, one for each Retrologue track.

When starting playback on my computer MIDI is sent from the GA track to the Retrologue tracks and their sounds play as expected. Once the playhead jumps from the end of Cycle to the beginning of Cycle I hear one more kick drum sound and then the tracks go quiet.
However, the MIDI Monitors show a transmission of MIDI data and the Retrologue UI indicate incoming events at the very top (flickering orange light) - but there is nothing happening on the keyboard of any of the Retrologues.
So - where do things go wrong?

I am asking any of you for a counter-check to see if this is happening only on my computer.
Does anybody have 10 minutes of their life left over for this?

1 Like

Johnny, I will have this checked within the hour.

Edit: It’s the same here. Upon looping, one kick and it stops.

Edit 2: If you let it run, the 5th time it loops around, does your retrospective recording field in the inspector go crazy? Weird stuff.

1 Like

I did not know that Cubase has a built-in disco light feature…
Disco Light

Thanks for checking.

@Martin.Jirsak , can you have a look on Mac?

1 Like

I have bookmarked this one, I’ll check when I have some time.

As for the Retrospective Recording I have seen this already. It does this when the track receives MIDI from another plugin. It blinks as if it was refusing to keep MIDI data in its buffer.
If you ever manage to click on it and insert it on the track it’ll probably do some funky things.
I did that in the past but don’t remember the outcome, I might check that again as well, for science. :joy:

1 Like

Here are my results with Johnny’s project file :
I don’t have Analog Techno installed, so since the first track is silent it’s much easier to hear the issue – or, just cut the volume inside the plugin.

I experience the same issue.
However, when it loops around and the sound is gone, I can still see some activity on the VU meters.
If I open a spectrogram and adjust the levels I can clearly see the sound going.
Now, when I increase the gain by any means up to an audible level (you need around +60 dB so put a limiter after the gain plugins, just in case), the sound is indeed still there, although somehow altered (for some unknown reason the kick lacks the pitch decay, instead it is a flat pitch)…

So one sure thing is that the MIDI data still reaches the instruments (MIDI Monitor shows traffic, as stated by Johnny). We can even tweak the Retrologues and hear the sound change, so the plugins seem to be working fine.

Now this is where it becomes funky :

When I replace the Retrologue instance by Padshop or Groove Agent SE, or any other 3rd-party instrument, this weird volume issue is no longer exhibited for this track, so you might think this is a plugin related issue, right?

Well, try with HALion Sonic SE, and you will see that this plugin also exhibits the issue. However, on some patches like Early 70s E-Piano or E-Piano MW Strings, the volume is only slightly reduced and the shape of the sound is altered, and we can still hear it without having to use gain plugins. Weird, ugh? So certain sounds are less affected than others by this issue?

As an additional experiment, I only kept the first Groove Agent track and duplicated it one time, and its MIDI input set to the first Groove Agent output (same setup as when loading the project but with the same sound on the two tracks, and the first track not monitored (the one with the MIDI part on it).
During the first run it will sound twice as loud (normal), but as soon as it starts looping around, there is a MIDI timing issue and the sound will go out of phase. Well, the offset is a bit longer than just a phase shift, so this is more like a very short delay. Note that it does this with any instrument that is inserted on the second track, although if the sound is different it is much less noticeable, but we can still hear the difference between when we first hit play and when it loops again from the start, even with drums + piano or whatever combination.

When using a standard MIDI track instead of the instrument’s MIDI output, there is absolutely no issue whatsoever.

It is therefore almost sure that this weird behavior is linked to the use of the MIDI output from Groove Agent exclusively, because this is none of an issue when using MIDI outputs from other plugins (TAL-Drum for instance, as shown in the video from the first post).
The main issue that it triggers subsequently, that is, the volume drop upon loop, only seems to affect Retrologue and HALion Sonic SE, but to me it is perhaps related to the more global timing issue that it provokes, somehow these specific instruments are particularly sensitive to it.

End of research. :grinning:


I can confirm Louis’ observation that the sound is actually not gone but very very quiet.
Raising the Gain of the Pre section on the Retrologue tracks lets me hear the sound.

If I use Dexed as a replacement for Retrologue the sound is just gone after cycling. Not dampened but completely gone.
Same result with another free VST synth - Vital.
However, with Padshop 2 the sound will be played back even after the cycle.

Additionally: Using Dexed as the source for MIDI rather than GA5SE the sound will play back normally, even after cycling also with Retrologue. (This as an additional info to TAL-Drum working.)

So, this is another weird Cubase (or possibly plugin) behaviour, which only occurs on Thursdays between 3pm and 6pm and only if it is raining? I keep running into these, I am so glad I am using Cubase only for a hobby reason and not professionally.

1 Like

One additional thing that I forgot to mention.
In my initial project after the sounds disappears/is dampened - you can reset the problem by

  • stopping playback and restarting it
  • using Rewind or Ffwd buttons/key commands
  • clicking in the project ruler to set the playhead to a new position
  • moving the mousewheel on the Primary Time display in the Transport bar

Everybody can see the pattern, I guess…

1 Like

You’re right, I tested again today with more instruments and I observe that the issue is in fact present with a lot of them.

With some instruments the sound seems to be completely gone (Soundspot Union, Synthmaster Player, BX_Oberhausen), in a way some patches will either show a totally blank specrogram or extremely low signal.

Some other instruments seem to be unaffected by the issue (Klevgrand), but more on that later.

However, most instruments (UJAM, Air Music, XLN Audio, Spitfire, Proclethya) exhibit the same “half-issue” as with certain patches from HALion, in which the sound is altered after loop, just as if some of the instrument’s parameters had been tweaked. For example with patch A it sounds brighter as if the filter was tweaked, with patch B the release is shortened and it sounds like a short click, with patch C the volume drops drastically, and with patch D the pitch/frequency is slightly different, or a combination of all the above (that was just a few examples but you see what I mean). Note that the controls do not change on the UI, this all seems to happen internally.

With Arturia, depending on the patches, it is either volume completely gone (still shows some signal) or parameter change.

My final guess is that the combination of the GA MIDI output and Cycle makes it send spurious MIDI/VST messages when the cursor reaches the end of the range and loops back, which changes the internal parameters of the instrument until we stop playback.
Earlier in this post I said “more on that later”, because actually, even if the instrument seems to be unaffected, it still is, but we don’t hear any change because the internal parameters probably aren’t mapped to the same IDs the bug is affecting. This would explain why the results are different depending on which instruments and which patch is used.

Now it would be great to test with more plugins that can output MIDI.
I wouldn’t be surprised if this isn’t just isolated to Groove Agent. It’s good to know that TAL-Drum and Dexed don’t produce the issue, but if this comes from within the VST code, a few third-party plugins will most probably be affected too.

1 Like

Ok. 99% of what’s going on, I don’t understand. But let me tell you another one, to get it off my chest.

Components: BFD 3, Pianoteq 8, Arturia CS-80.

I select BFD 3 as a MIDI input for both Pianoteq and Arturia CS-80.

  • If I draw some events on BFD’s track, I get no sound from the other instruments, BFD just plays what’s on the track, and it gets no further than that.

How do you guys manage to put out the data from the track to the other instruments?

  • If I let BFD autoplay from its internal groove engine, all instruments play fine.
  • If I then activate cycle, CS-80 stops playing completely, while Pianoteq keeps playing exactly as it did before, but the keys don’t light up anymore, when just before the cycle they were lighting up fine showing what notes were playing.

Now, as I said, I don’t know what the actual… is going on, but I think this is on each plug-in. I suspect that since the standalone version of Pianoteq features a MIDI player and recorder, maybe it “syncs” with the host’s transport and doesn’t get “lost” when the time to loop comes? I really don’t know. Very interesting, weird stuff.

1 Like

That’s how the MIDI Out from a plugin works, the plugin itself needs to send the data. The MIDI parts that are placed on the track aren’t passed through directly like a MIDI Thru.
For Groove Agent the notes are linked to the pads, and these same pads, when they are triggered, send MIDI messages to the MIDI Out. While it’s automatic with GA, it may be different with other plugins, so in the case of BFD you figured out how to do it ; activating the internal sequencer.
(I believe it’s intended for writing the sequence that plays from inside BFD to a MIDI track, but doesn’t it have drag and drop for this? Maybe a setting you’re missing? Honestly if it can’t do some sort of MIDI Thru, I don’t see the interest of having a MIDI Out, especially if it has drag and drop already. I don’t have this plugin so, just asking.)

So now we know that it is not limited to GA. Thanks for investigating.
I don’t have more plugins with MIDI Out so I can’t test any further unfortunately. I hope some people will join in and share their experience.

Very interesting and weird indeed.
I think none of us know what the actual… is going on :joy:

1 Like

BTW: In my project when the Retro’s are dampend already I can record on any of those tracks. They midi events from the GA track will be correctly recorded (and sound plays back nicely).
This solidifies the MIDI Monitors display that the MIDI data is not tampered with.

1 Like

Ah ok, I think I understand now. BFD has 3 modes.

  • One, Grv. Off. In this mode, it just plays what’s on the DAW’s track.
  • Two, Track. In this mode, it plays what grooves have been laid out in its internal track sequence.
  • Three, Palette. In this mode, it auto plays grooves from its palette (randomly, or with a certain purpose).

Both modes send out MIDI to other tracks. I got confused because of the MIDI modifiers (that I hadn’t noticed in the test project). I was wondering why the test project instruments play so sparingly, but then I removed the modifiers and I got them doing the same with BFD.

Just now, I did another test.

I used the Arranger Track. (4 bar parts, 3 of them, left some 3 bar spaces between them, then set up a A, A, B, C, A, A chain)

The same behaviour, with some twists. The instruments drop out and drop in again at different sections, as if they didn’t get the sheet music in time. :grin: :thinking:

First A, all instruments play. Second A, only BFD and Pianoteq play. At B, only BFD and Pianoteq keep on playing. At bar 15, start of C, Pianoteq doesn’t play at all, only BFD is heard. And now for the best part. At bar 17, halfway through C, ALL instruments start playing, they loop around to the A, and stop playing at bar 3, leaving again BFD and Pianoteq alone until the end.

And now, I did one more test. While this whole deal was evolving, I thought “Why not record the incoming data of the monitored tracks?” And I did. And I was surprised to see that I had events being recorded one or two measures back from where the playback cursor was at the time.
recording monitored tracks


I think I’m going to lie down.

1 Like

Yup. That’s definitely broken. :grimacing:

This issue seems to be fixed with the maintenance update of GA(SE) to 5.1.20
The problem is gone on my machine.

1 Like