Soundtoys/Ample Sound plugins very slow loading session in Cubase 11

Hello, I have been struggling with a very annoying problem for many months - when loading a session containing Soundtoys plugins, the session hangs for about 20 seconds when it is detected on a track (Insert, FX Track, Group Track). Ample Sound instruments also take a long time to load. All the others such as Waves, Softube, FabFilter, Valhalla, iZotope, PSP and many others load without any problems.

It looks like:

This only happens the first time. When I close the session (not Cubase) and reload, it’s very fast. Many weeks of conversations with Soundtoys support did not help (including the installation of a new version). Windows 10 was also reinstalled.

I recently found something like this: SOLVED: Waves plugins very slow to load - Support - Waves Community Forum

And after many attempts, when I disabled the LAN card in the BIOS - the problem was solved! Now the sessions with Soundtoys loads in 2-3 seconds. Only no LAN means no Internet, so it makes no sense :slight_smile:

I tried removing all network drives - no helps. I deleted network profiles - HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\NetworkList\Profiles - with no effect. And also this - HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Map Network Drive MRU. Also no effect.

For a while, when I removed all network drives from the system and changed to another router, opening Cubase for a few times was OK, but then the problem returned. It’s the same on WiFi. The only thing that helps is disabling the LAN in the BIOS or disabling the driver in the device manager (ASUS STRIX X299 E GAMING).

Even if it worked, it’s not a solution! I have been using network drives for the Back Up and Upload directory since 2008 and I don’t want to give it up.

Regards
Adam

Hi,

Is this plug-in using iLok by any chance? Or how is it protected, please?

Hello, Thank You Martin, for the answer :slight_smile:

  1. Soundtoys plug-ins use PACE software and can be had on both physical Ilok and PC. In my case, the studio computer is on Ilok2 but I tried to move the license to PC - it works just as slowly and badly.

However, I have had iLok 2 (formerly iLok 1) and Soundtoys for at least 10 years and everything has always been fine. Problems have been occurring since autumn 2023.

  1. Ample sound does not use iLok software. Here is the Key Code.
    https://www.amplesound.net/en/Installation_and_activation.pdf

On my Lenovo old laptop from 2014 (i7-4702MQ, 16 GB RAM) with identical software (Win 10 22H2, Pace 5.9.0, SoundToys 5.4.1.17134) there are no problems, everything works super smoothly BUT I don’t use here the physical iLok2 key - I keep the license on the PC (second license available for use).

Regards
Adam

Hi,

This might be the culprit then.

You can also try to use ProcDump to generate a DMP file (if the file would be generated in this case) to see, which component is hanging.

Generate a DMP file and share it via Dropbox or a similar service, please.

Use the Microsoft ProcDump utility to generate a DMP file, please.

  1. Please download ProcDump64 from Microsoft (~650kB) and extract the archive to a local folder on your hard disk.

  2. Run Command Prompt (cmd) as administrator (right click and select “run as administrator”)

  3. Navigate (in the Command Prompt) to the folder with the extracted procdump file.
    For example:
    cd C:\ Users \ \ Downloads \ Procdump
    Note: the dmp file will be written into that folder.

  4. Launch Cubase/Nuendo. You can work as usual. At any time, change to the command prompt and start procdump, to monitor Cubase/Nuendo for unexpected behavior (see next step).

  5. Launch procdump64 via Command Prompt:
    Cubase 13:
    procdump64 -e -h -t Cubase13

Nuendo 13:
procdump64 -e -h -t Nuendo13

The -h option will write a dmp file in case of an application hang. This might kick in too early sometimes, in case some action takes a little longer. Feel free to skip the “-h” option, if you are only up for fetching crashes.
The option -e will catch exceptions and the option -t terminations of the application.

  1. Prodump is now monitoring the Cubase/Nuendo process and will write a crash log, in case Cubase/Nuendo crashes or hangs. Perform the action that causes Cubase/Nuendo to crash and send us the generated crash dmp.

ZIP and share the DMP file via Dropbox or a similar service, please.

Hello, I am sending you a link to my DMP.

The last DMP number is with LAN disabled - when cubase starts quickly.

During the test, the following information appeared:

EchoBoy V5 could not be loaded. Please contact…

Error details:

Bad WrapConfig Auth Data

So it looks like you’re right with iLok2…

Best regards
Adam

Hi,

The error message says it all.

Fatal error - EchoBoy V5
Please, contact the software publisher.

Hello, were you able to analyze the DMP files?

Does this mean that iLok2 is slowly dying and needs to be changed to iLok3?

Of course, I will contact Soundtoys, only they provide 2 licenses which seem to be correct - they probably won’t help much because the problem is on my side.

However, Ample Sound also loads slowly and its license is not related to iLok - perhaps a damaged/beginning to fail key is causing the software to crash.

regards
Adam

Hi,

The crash point to Cubase. But I think, it comes from the plug-in, which crashes (as you can see, the Fatal error appears) and te plug-in crashes Cubase then.

I did an experiment - I transferred all licenses from iLok2 to PC (those that were transferable, i.e. most of them) and the effect is the same. And I disconnected the iLok. So the iLok2 key is working properly.

Only disconnecting the LAN helps (as before).

Support Soundtoys wrote:

“If you’re currently using iLok to handle any other plugin licenses, please make sure that you are running the most up to date versions of these other plugins. My understanding is that older versions may be using outdated calls to iLok’s servers, which can lead to conflicts.”

I always have plugins in the latest possible version.

iLok support recommended reinstalling iLok License Manager and uninstalling the antivirus software for a while.

Nothing helps.

Does anyone know what the connection is between disconnecting the network and slow loading of plugins such as Soundtoys or Ample Sound (it’s possible that other plugins and instruments may also get stuck while loading)?

Maybe there really is a problem with network drives?

Maybe this is a hint:

However, resetting the network does not help and Windows 10 is clean (just installed)