Space bar adds midi notes

Since upgrading to Cubase 12 pro, and maintenance update
I have been bugged with the space bar adding notes in the piano roll editor, i have taken out (uninstalled) my other midi remotes and got rid of a usb hub.
But it still happens
Anybody had this issue?
Thanks in advance

Hi and welcome to the forum,

My expectation is, you have some Mackie control enabled and some MIDI loopback involved.

If you hit spacebar, Cubase sends MIDI Message to the Mackie Device to let it switch the Play button On. So this is how is the MIDI Message created. This MIDI Message is most probably somehow looped back to Cubase (All MIDI Inputs) therefore it becomes recorded.

Double-check your MIDI routing, please.

All good now. I unticked the send ccs in kontakt weather that was the fix im not sure. Also got rid of a usb hub. But all is now working. I could go more into depth of that if anybody has the same problem.