"Space bar" doesn't work by lyric input

By inputting lyrics in dorico pro 4, if I press the space bar, the cursor should move to next note for inputting lyric on it. Yes, it works fine, only if the lyric constituted of alphabet or numbers. However, If I try it in korean, space bar doesn’t work as expected, rather than it works like space bar in normal situation. I mean, it makes just “space” between letters as if it is an usual text. So, it is very hard for me to input lyrics for my korean choir. Does anyone experience same problem? How can I fix it?

It sounds like the Space character generated by your Korean keyboard layout is different from the Space Dorico is expecting. You don’t normally type a fullwidth space in Korean, do you? (In Chinese and Japanese they usually do.) Ascii Space is U+0020; fullwidth space is U+3000. Perhaps try ShiftSpace and see what happens?

A robust solution would be to add your Korean space as a keyboard command in Preferences > Key Commands > Note Input > Advance Lyric Input.

Thank you for your kind and precise answer. Unforturnately, it’s not the case, if I understood your answer properly. There is no difference between “korean” space bar, which isn’t the fullwidth space like you said, and english one. I tried also ‘shift + space bar’, but it doesn’t work. If I type an alphabet and switch my keyboard to korean, and then press space bar, it works. But if I do it oppositely, it doesn’t work. So, I think it’s not about the difference between korean or english space bar, which are actually identical.

Hmm. Disappointing.

To the Team: Is it possible that, using a different keyboard layout, the same physical key can generate a different keycode, which then enters the same character anyway? Is there a processing layer in Qt that can complicate this?

This is a known issue with Korean lyric input on macOS, I’m afraid, and it’s on our backlog to be taken care of.

At the moment, when the Input Method Editor is active, we will only advance lyric input when we receive the ideographic space character (U+3000), because that’s what’s used in both Japanese and Chinese, since the regular space character (U+0020) is used to confirm the choice in the IME.

However, in Korean, the syllables are built up in place and Space is used to separate words. But unfortunately Space won’t advance the lyric popover when typing in Korean, so you have to switch the IME back to English or another non-CJK input at the end of each syllable or word, which is obviously pretty time-consuming.

Ah! So I had the problem backwards.

I have spent some time fiddling with this, and I think the way I would work around it is:

  • Type all the lyrics in a separate program, adding a regular space after every syllable (even within words)
  • Copy the text, switch to Dorico and Paste it in a syllable at a time. This way the popup advances normally.

Edit: I tried adding ー for each note of a melisma (also separated with spaces) but that makes all the text paste into one syllable! Perhaps Koreans don’t use the Japanese long mark U+30FC for this and just use a Latin dash such as –. (I don’t know how to type an en-dash with my Korean keyboard layout, but one could search & replace hyphens.)

Yes, I also run dorico on my macbook. Well, it’s already a known issue. OK. Then I wait for the next update expecting the bug will be fixed.

Can I use dorico on my windows computer simultaneously with the same license? I work most with macbook, but if there is no problem to input lyric in korean on windows platform, I’ll try it.

Thanks a lot for your comment. At moment, I use the Arrow Keys to move to next note, although it can’t express melisma, but for now it’s most convenient. I wait for the next update.

I use Dorico Pro 4 on my Macbook and Windows 10 PC simultaneously with no issues at all. I save all my projects into iCloud (which I have installed on the PC) so they’re accessible from both computers.

2 Likes