Spacing priority

The following spacing occurs in a very full system. The part without the accidentals seems to dictate the spacing, rather than the part with the accidentals. Is there a setting that would prevent this?

Here’s another example. It’s only slight overfilled, but there are still collisions of accidentals that could be avoided without injury to the spacing of the other part that has no accidentals.

If you reduce the Note Spacing value, does that help? There’s also a value for the minimum distance between short notes.

The first example looks like you’ve got optical spacing for cross-staff beams activated, which doesn’t play as nicely in layouts with more than one instrument (ie this is best used in just the part layout for that one piano/harp etc, rather than the score) because it has an impact on note spacing columns that are shared by all notes in the system.


Nice tip!

That was the setting I was hoping for. Thank you @Lillie_Harris! It improved the first example greatly.

The second example was, of course, unaffected by that setting and, while it is easily fixed manually, it is not clear to me why it would not be better spaced since there is room in the other part.

I had played with that but it doesn’t seem to change anything in this case, perhaps because the second example is 101.5% full. @benwiggy

Here’s five bars in a system, at 3 and 1/8 Note Spacing.

Here’s the same bars, at 2 and 5/8ths.

If the Note Spacing is reduced, then the fullness % is also reduced.

Of course, as you point out; this may not be relevant to your problem. :laughing:

@John_Ruggero, even if the system ist just a little bit over 100% full, Dorico may not do it’s best work. But once under 100% most of problems like the one in your example will be gone. See the gif.
notespacing change


That was the second part of the puzzle @benwiggy. @rafaelv. Thank you both for the visual demonstration. I wasn’t adjusting the quarter note value, just the minimum for short notes. As you said, once it went below 100% everything cleared up. Interestingly.some of the other systems improved as well even though they remained above and sometimes well above 100%.

So I now have the quarter note at 3 3/4 and the minimum for short notes at 2. I don’t remember what the Dorico default is.

The default ist 4. You can just insert another note spacing change where you want to go back to the previous values and select reset in the Note spacing change Dialog
When in doubt you can use the Library manager to compare the settings of your current project against the factory settings, your own (user) default settings, or another project.
Library manager

Thanks for those tips, @rafaelv! The Library manager is new to me. Very helpful. I will need to study your tutorial.

1 Like

I will marry the Library Manager as soon as it becomes legal. Well, maybe not marry. After all, there might be something better that comes along and I want to leave my options open.

1 Like

The minimum for short notes default is 1 and 3/5ths. The default for Note Spacing (4) is quite spacious, IMO, and I bring it in to 3.5 or 3 and 1/8th for lots of things. If you’re using larger note values, e.g. lots of minims, then you can go a bit below 3.

A metre like 3/8 needs to go back towards 4, as does anything with lots of small note values.

1 Like