I’m having weird day today…

How do I make Dorico think again about this spacing?
It seems to be spacing by lyrics and hashing the notes.
There is plenty of wiggle room.
Nothing is forced.
Quiet 1.jpeg

Dear Steve,

Nothing is forced… except there is a System break!
You might want to give some space to those bars — you could change space size, change lyrics size, actually there are many options that you could choose, but I agree it does not look right :wink:

I want four bars - there is plenty of space for everything.

In the Engrave menu note-spacing I can make it look right without changing space, lyric etc.

There must be some way to make Dorico ‘think’ again?

This is the kind of hash you get in Finale that Cmd-U magically fixes.

That looks like a very narrow system to me, so Dorico is under duress (it would only put three bars on that system if you weren’t forcing it). Try reducing the default note spacing value on the Note Spacing page of Layout Options (you can do it just for one system using a Note Spacing Change if need be, with a restorative one at the start of the next system), and perhaps also try reducing the minimum gaps between lyrics on the Lyrics page of Engraving Options.

I can space it nicely manually.
Fiddling with lyrics, lyric space horizontal adjustment and hyphens gets most of the way automatically, but mucks up systems that I’m happy with.
Is there a way to apply these to just one system?

You can apply a note spacing change (set to reset) at the start of the next system, and then apply a note spacing change at the start of this system.

Alternatively you could apply a staff size change to the next system (check Layout Options for what your regular staff size is and type that number in) and then apply a staff size change to this system (put a slightly smaller number in the box).

Can I do that with Lyrics prefs? I think the answer is no, but that is very limiting.

I don’t think so, but be reasonable here - you’re trying to squeeze WAY more onto that system than Dorico wants you to!

Way more than Dorico wants maybe, but it’s easy to fit it in manually in engrave mode. (And Finale does a decent job of spacing it, off the bat).

Fixing it manually in such a way that the pianist can read it, as well as the singers?

Here’s another. Exactly the same settings. Three bars in the system are really spaced out.
Make into system with four bars produces the attached.
Dorico seems to be giving up, rather than trying to space it.
Quiet 3.jpeg

Turn on Note Spacing in Engraving mode and see what percentage figure Dorico gives you. If it’s more than 100% Dorico WILL struggle, and, in my experience, if it’s more than about 110% it just can’t cope. If you’re repeatedly coming across this issue, you really need to consider changing a global setting.

I’ll keep trying. Thanks Pianoleo!

Actually, there’s a potential hack here. I’m guessing you’ve not used the “translation” lyrics line anywhere in this project. You could select the lyrics on just this one system, set them as “translation” and then go into Fonts and reduce the size of the translated lyrics style.

That way your lyrics would be slightly smaller in this one system, which might give you the wiggle-room you need.

I’d thought of this. But reducing the lyrics size is not possible. Squeezing them up by changing notation options works well for that system, but creates hashes elsewhere.

+1 for the ability to apply changes to the lyrics spacing settings locally.
Also, I would really appreciate an option for excluding lyrics from the spacing calculations, both globally and locally.
(Dorico does a very decent job at spacing lyrics, but in my opinion, whatever settings you choose, lyrics still cause too much distortion to the general spacing. No complaint, it’s the same with any other software I’ve used. I’d be perfectly happy to do it manually, but it would be good if I could start off from a ‘clean’, un-distorted spacing calculation.)

Steve, since you are generally forcing the number of bars per system, you will find that reducing the ideal spacing value on the Note Spacing page of Layout Options will have less impact than you think it will; likewise reducing the minimum gap between lyrics. You clearly think that in fact the spacing should be narrower, and that the allowable minimum gap between lyrics should be smaller, so rather than expecting Dorico to read your mind, try actually, you know, changing those options so that it can do a better job for you.

Hi Daniel,
I have changed the lyrics options as described above. This gets this system close to what I want. But… this messes systems that I was previously happy with.