SpectraLayers Key Commands are meant for the Standalone version only? [solved]

Hi ppl! :slight_smile:
As per the header SpectraLayers Key Commands are meant for the Standalone version only and not as ARA2 extension? I’m trying them in Cubase. Time to give up already? Just curious. :slight_smile:

Windows or macOS ? Make sure the SpectraLayers UI is in focus (click inside the spectrogram) before pressing a shortcut. A good test is to press “G”, which enables/disable the grid in the spectrogram.

G? Hmmm …
“Add selected tracks to group” is not a SpectraLayers command, correct? :rofl:

It’s the same on Mac.
When in ARA mode wanting to delete what is selected (backspace) I instead end up deleting the selected part in Cubase (where I came from to edit in SpectraLayers), resulting in SpectraLayers closing. In Sprite of SpectraLayers being in focus.
And when using the key command for ”undo” the resultat will be that SpectraLayers closes and I’m back in Cubase. Usw.
This has been a pain from the beginning of the ARA implementation of SpectraLayers and has been pointed out before.
With Melodyne in ARA mode the key commands function flawlessly.

1 Like

@HowlingUlf I’ve tested SL 10.0.20 against both Cubase 12.0.70 and the upcoming Cubase 13, no issue with keyboard shortcuts. Pressing “G” properly show/hide the grid. Make sure you clicked inside the spectrogram before pressing G.

1 Like

@Marshall performing the same test with SpectraLayers 10.0.20 and Cubase 12.0.70 on macOS works as expected : G show/hide the grid, and Cmd+Z performs the Undo in SpectraLayers, as expected. Again, make sure you clicked inside the spectrogram before applying shortcut, the white rectangle around SpectraLayers UI is not enough to guarantee SpectraLayers itself has the focus, it just shows that this area (including Cubase’s Add/Remove buttons) has the focus, but not SpectraLayers itself.

Here’s a video of G and Cmd+Z shortcuts working in ARA mode:

The key commands seem to work when I have the lower zone in Cubase open.

But if I have SpectraLayers open in a separate window on a 2nd screen they don’t work properly.
When I tried today to erase the content of a selection with Backspace it actually worked, but undo with Command z did not.
And yes, the SL window was active as per Robin’s instructions, since I had used the erase tool in SpectraLayers and then directly hit Command z.

Yep! Confirmed !!! :sunglasses:
13 ??? :open_mouth:

Anyone that gets the key commands to actually work properly in ARA mode when not using SL in the lower zone but in a separate window (on a second screen)? On Mac?
@Robin ?

So far as I was only able to connect to a secondary monitor through AirPlay, but shortcuts were working as expected when SL was on that secondary monitor (and Cubase still on the primary monitor):

Thanks for checking!
Can’t get it to work though.