SpectraLayers Pro 7 system reboot when unmixing Stems

I’ve just taken advantage of the Black Friday deal on SpectraLayers Pro 7 and my system reboots when Unmixing Stems. I was aware of this problem in the bundled SpectraLayers One free program that came with Cubase Pro 11. but for it to be in the “Pro” version too I am really not impressed.

I contacted Robin Lobel (who seems to be in the development team) by email about the problem last week and he didn’t even respond directly to my email! He seems to expect us to do all the running!

If I’d put out a program with such fault I would be embarrassed and apologetic. I am sure it we will get to the root of this eventually but it is not a good start!

Wow , look at all your system spec and information , thats really helpful for trying to solve your issue , Have you ever thought because spectral layers works for nearly everyone else you have a problem with your system ?? Nooooo just shout off with no info and make your self look stupid .

I remember why i don’t get involved in forum’s , cheers for reinforcing my original theory that 80% of forum goers are … :unamused: :unamused: Embarrassing

I see. The real problem here is that you’re embarrassed. The rest of us will try to keep that in mind.

It’s certainly a pain in the butt. I have some experience with stem separation using another app, but your problem is a puzzler to me.

It’s the same binary application - so issues you’re having in One will likely be the same in Pro. There’s also a 30 days trial version of Pro.
We’re working on this issue, but please understand it’s quite a complex one that needs time, as only a few computers show it right now and we were not able to repro it on any of our computers here so far.

Would a Windows 10 clean install help? I’ve done a Video driver reinstall (using the AMD driver cleanup utility) but it made no difference. I am using the latest Microsoft Certified driver not a beta and yes I have set the driver to Open GL in SL7

I am glad I bought the full program as it is currently available half price in the Black Friday sale and I have faith in you Robin

Just as well this is not a COVID vaccine we are dealing with here :wink:

If you feel doing so, a clean Windows 10 reinstall from scratch (a real clean reinstall, formatting your main hard drive, not just reinstalling over Win 10) would certainly help indeed. I feel like there’s some strange driver or kernel issue behind this. A software alone is not supposed to be able to cause such a hard reboot.
Let me know if that helps ! Please install and try SL before installing any other software or specific drivers, just to check. Then gradually install the rest of it.

Same issue here. This was the main function I wanted from this purchase and am a bit bummed out. Hoping for a fix soon. Feeling some pretty nasty buyers remorse over here. :open_mouth:

Not going to reinstall my whole OS as most all of us, it would set me back a couple days to reconfigure. Yikes.

It seems the issue is actually CPU under-voltage. Try the fix here: https://www.steinberg.net/forums/viewtopic.php?p=1077030#p1077030

I solved this problem by disabling HiDPI

I have lost confidence in this program

Why should I have to fiddle around with my system which works for pretty much everything else I throw at it for the sake of this one program? It’s not acceptable and in my opinion should come with a health warning!

Again, a software by itself can’t cause such instability: modern OS (such as Windows 10) have all sort of sandboxing to prevent this.
The only low-level components that can cause this behavior are either device drivers, or hardware failure.
In every report here, it happens when all your CPU cores are used simultaneously to the max of their capacity (unmixing process). So it’s not unreasonable to suspect a failure from the CPU, or overheating, or some low level management related to it. Even when a DAW is under heavy load, it rarely use all cores to their max capacity (including all available SIMD instructions) continuously.

Have you tried raising the CPU voltage has suggested here ? It fixed the issue for this user.

Other fixes related to the “Kernel Power” reboot (ID 41) all points to power or overheating issues (and sometime driver issues): https://blog.pcrisk.com/windows/12891-how-to-fix-kernel-power-error
https://forums.tomshardware.com/faq/how-to-fix-windows-10-error-event-id-41-‘kernel-power’.2752245/
https://ugetfix.com/ask/how-to-fix-kernel-power-41-error-on-windows-10/
https://www.minitool.com/backup-tips/kernel-power-41.html
https://reduxzone.com/windows-kernel-event-id-41-error/

Silly take. Softwares don’t all have the same system requirements, some require much more CPU, newer hardware, etc, etc. This is true with video games, visual effects, scientific data compiling and calculations, 3d rendering, etc, etc.

To the last poster, OK so tell me what changes I need to make to my system in order to run it without random reboots which will likely eventually knacker my hard drives? Or are we all paying guinea pigs?

Did you change anything in your BIOS? are you overclocked? hyperthreading on or off? which type of graphics card? Did you calculate power consumption correct for the powersupply? are the cooling fans spinning? have you done a RAM check, could be bad ram - might have to take your ram out and put back in one at a time (with computer off obviously).

could be a lot of things. but, thinking about SL being graphics intensive -im wondering if your graphics card starts to suck more power than usual and your PSU isn’t keeping up.

I was able to fix this issue in my ASUS motherboard BIOS settings

Look for an option for “CPU core ratio”.

Mine, by default, was set to “per core”. I switched to to “Auto” and BOOM it fixed the issue.

Something about how the core’s resources are allocated is causing the reboot in my case.

I’ve unmixed 20 tracks without incident.

Hope this helps.

Here is a Dropbox link to a video I took from my phone of exactly what I did.

https://www.dropbox.com/s/jnufkhq4xozlho2/Spectralayers%20Fix.MOV?dl=0

Issue here seems to be what is being called “CPU under voltage” in so far as if I overvolt the cpu from default settings I can survive unmix stems.

I should not have to do this with anything let alone a basically non real time process.

RX8 never causes such a problem with the same / similar operation on this machine even though the same amount of time is taken to process.

I wonder if the usual recommended audio machine bios settings set by Steinberg are not the best ones to use with this program?

There is really no need to hammer any machine with a non real time process IMO.

Hippo

Do your problems happen on short, say 1 bar events, as well as long/entire song?

Hippo, I just did the following test on SL7 and RX8 with my Core i7-9750H on Windows 10, unmixing a 44100Hz stereo song which is 3 min 27 sec long:
RX8 (default settings, 4 stems): 55 seconds = 13.75 seconds per stem
SL7 (default settings, 5 stems): 20 seconds = 4 seconds per stem

So SL7 is 3.4 times faster performing the unmixing. It’s likely consuming more CPU power than RX8 during that process.

This is confirmed by the CPU usage graph during the unmixing:
RX8:

SL7:

I agree you should not have to tweak your BIOS settings, but in that case it’s purely due to hardware settings not being set to be stable under heavy CPU load. Fortunately the BIOS settings let you fix it.

Ok
Thanks for taking the trouble
No sale here even at half price
Others may disagree.

Hippo