SpectraLayers won't update. Says Soft eLicenser is missing

Trying to install Cubase 11, latest update. Everything went smoothly, except SpectraLayers (free version) won’t update.
On the PC that I’m installing on, the System Drive is the “D” drive.
I have another PC with “Normal” drive layout (C = System drive) & the update was fine on that PC.
I’ve tried both within Steinberg Download Assistant, and also manually installing the downloaded SpectraLayers updater.
I always get the same message
“Please Install the E-Licencer before installing spectralayers” (or words to that effect.)
The eLicencer is, of course, installed already & fully up to date.
The updater then throws an error in the Download Assistant, and closes.
So it seems like the Spectralayers installer, that came within the latest Cubase 11 update, is looking for the eLicenser on my “C” drive, instead of on my System (D) drive.
I wish I’d never installed Win 10 on D … (SSD upgrade) & I’ll change it back next time I’m forced to do a total re-install of Everything, strangely though this is the first time in 4 years or so that I’ve had any problem crop up because of it !
It may be that it’s not the C/D drive thing, but as nobody else has reported any problems installing the Spectralayers update, I’m guessing it is??
Thanks in advance.


Just to be clear, are you talking about Cubase Pro, right?

I’m afraid, this really might be the issue. I have seen some update issues when Cubase has not been installed on system C drive.

To know the exact message (or the screenshot) could bring some light (maybe).

I’m afraid it is.

Sorry, it’s been a while since I’ve posted, I wasn’t very clear.
Yes, the latest Cubase pro 11.2 update.
Using the Download assistant…
Cubase pro 11 update tab
Sys drive = D
Cubase & dongle updated fine
Spectralayers failed
Halion sonic & GA OK
Padshop & retrologue fine
Various soundsets ok.
I can’t grab screenshots till tonight.
Message was that License center needs to be installed first. And another that said to try and install the downloaded updater manually, as it has downloaded, but “unknown error”.
As everything else worked on D drive though, surely this points to an error in the coding of the Spectralayers part of the installer.
Somebody has typed
“Check for dongle on C:\users\etc” instead of
“Check for dongle on Sys Drive\users\etc”.
Surely this error can be easily checked & put right, without affecting anything else?
Thanks for quick reply btw.