Speed up Media bay - takes ages to scan!!

The Media bay / vst preset system in Cubase literally takes 5 minutes to scan every time I open the media bay after opening cubase for the first time, and I’m on SSD’s and dont have that many custom vst presets! I dont understand why it seems to need to rescan every time a project is opened!

Steps to duplicate issue on your own system.

  1. Open cubase (this happens when you first open cubase so you need to have the program closed)
  2. Open the media bay
  3. Click on anything (instruments, loops, presets, etc)
  4. You will see the hexagon image scanning.

Alternatively you can simply open any plugin after first opening Cubase and try to load a preset. Again you will sit there as it scans, in my case, for 5 min before you can load a preset.

And once its done scanning, the media bay is still clunky and slow when loading presets (takes 2-3 seconds for every icon I click before I get to its options; e.g. click on “vst instruments” -> “groove agent” which then takes 2-3 seconds for me to see presets.

Every other DAW or software program I use does not have this issue (Logic, Digital Performer, Vienna Ensemble Pro). Their media bay equivalents & preset loading systems do not have to rescan every time you open the program, or if they do, they do it a way that does not stop you from working for 5min.

Oh yesss! that would be nice.

PLEASE! I can’t believe that this goes unnoticed since it’s becoming so important being in the right side dock…

It’s so awfully slow. You kinda have to decide between keeping your sample libs in there OR use Track Presets at all…

+1000

This is very annoying. In my case it appears to take a very long time on ‘VST3 Presets’, even though there aren’t many of them, and it’s not possible to deselect the folders causing the problem.

Something is up, because it happens to some users, and not others. I posted in another C10 thread, and a user there says C10 fixed it for him, It hasn’t for me though.

I agree that Logic and Studio One are instant in this regard, if they do scan, there’s no indication they’re doing it.

After a bit of unscientific testing, I’ve noticed that it takes 99% of the time to scan through unknown native file formats, such as from UHE and Fabfilter, and those are the ones it keeps rescanning, presumably because it’s unable to index them.

I guess this means the ‘Ignore Unknown File Types’ checkbox isn’t working?

Very interesting Jon Wright. Maybe its an undiscovered bug that can maybe be fixed (or at least helped) in an update? That would be awesome! Hopefully you can report it with the steps you took to get to that conclusion as an official bug report.

Yes please.

+1

+1. This mediabay is such a mess and barely usable. I can’t understand for the life of me why it keeps scanning over and over every time you open it. And all those tags. It’s so messy i just NEVER use it. Number one request for cubase 10.5 : an updated, simplified, snappy mediabay.

yes. Snappier please. Makes me (sigh) every time i open it …waiting…waiting…

+1

Crazy slow indeed

What’s the advantage of using Mediabay compared to the file browser in the right zone, which you don’t have to scan?

Okay.

After years of waiting ages for Cubase to scan the MediaBay, it’s suddenly started appearing/scanning instantly.

I haven’t changed any Cubase settings, it’s just suddenly working.

I’m changing the attributes of many samples at a time and MediaBay takes a long time to finish them. While the new attributes are being updated, media bay itself becomes practically unusable.

There are also some strange behavior when using search strings. Example: when using the search function, some characters in the search strings are simply ignored!?! The _ (underscore) character in a search like A is dropped, which means I cannot narrow down search results by key (for later bulk tagging of root key). It also seem to ignore the dash symbol “-”.

UPDATE: You can include special characters like _ and - in your search by adding a % symbol before. So if you are searching for _A# just enter %_A# and the underscore will be included in the search.

BTW, I don’t use track presets, because every time I do it takes a long time to load the presets. It’s a workflow breaker.

Please improve performance!

+1