Spitfire LABS instruments in Dorico

Hi,

I tried using a few of Spitfire LABS free instruments with Dorico.
The MIDI keyboard does not respond (even though Dorico shows a small green light in the lower right corner on a key press).
Furthermore, one a LABS component is loaded the keyboard does not work with any subsequent instrument (in my case a VSL and an EastWest one).

Their AU works as expected within Garageband.

I already wrote their support team.

Any thoughts?

Thank you,

Alex

For a first assessment, please open a Dorico project in which you try to use Spitfire, then choose from Dorico’s main menu ‘Help > Create Diagnostics Report’. That creates silently a zip file on your desktop. Please attach it here. Thanks

Hi Ulf,

Please see attached!

Thank you,

Alex
Dorico Diagnostics.zip (452 KB)

Sad news for you. Contained in the diagnostics report are 6 crash dumps of the audio engine. The engine recognizes Spitfire and loads it, but then it crashes in the Spitfire plug-in. 5 of the 6 dumps are from Spitfire. So you better get in contact with Spitfire as we can’t do anything about it.
And then there is one crash in Vienna Synchron Pianos. Also here, please notify VSL about it. But I wonder, Synchron Piano is a VST2 plug, but you also have the VST3 Synchron Player plug-in. Can’t that one also play the Pianos? I hardly know the Vienna plugs.

Hi!

I was able to run the spitfire labs plugins in dorico 3.0.1 without problems. However, before I updated to the newest e-licencer, there were lots of crashes with the audio engine.

With atudor there are also a lot of crashes in the audio engine, but those crashes are actually caused by the Spitfire plugs. So Spitfire crashes and consequently takes the audio engine down with it. I am interested about your case as well, sakasuri. Could you please also post a diagnostics report?

Hi!

Here is attached a diagnostics report of a Dorico 3.1 running spitfire LABS Drums. Just to be sure, it’s working absolutely fine with me! :slight_smile:

I’ve also attached a percussion map for LABS drum set, for anyone interested!
Dorico Diagnostics.zip (1.68 MB)
LABS Drums.doricolib.zip (1.53 KB)

Thanks for the data, sakasuri. You are running the same version of Spitfire as atudor. Also, there are no crash dumps contained in your diagnostics, so you haven’t had a crash for at least 2 weeks. Atudor is on OSX 10.14 whereas you are on 10.15, maybe that also makes a difference.

@atudor, with Dorico 3.1 already the latest eLC should get installed, but it is worth a try getting the latest eLC from our website (https://www.steinberg.net/en/company/technologies/elicenser.html) and see if it gets any better.

Hi Ulf,

I filed a report with Spitfire. They never answered. I’ll try again.
AFAIK Dorico uses Synchron Piano VST2 (I had to white list it). I suspect that the VSL crash you saw has to do with Spitfire. Once they load every other plugin crashes as well.

Thank you,

Alex

Thank you Ulf!
I already had eLC .2263. Did the diagnostics report otherwise?
Alex

Then I’m afraid there is nothing anymore I can do for you anymore. The suggestion with the latest eLC was just because of sakasuri’s comment. He/she mentioned crashes with Spitfire LABs that went away with installing the latest eLC. But I suspect there is no real relationship between the two, just happened to for whatever other reason.

Not helpful, but for info:
Dorico 3.1 and latest Spitfire Labs runs without issue for me on Windows 10.

Me too - on OSX. I have 3 LABS libraries (Strings 1 and 2 and the Dulcimer) and they all work as they should. I’m using LABS 1.3.3

Interesting … But, finally success!

The only significant difference I could see is the Dorico version (your Pro 3.0 versus my Elements 3.1).
Same OSX, same LABS. My H/W 16 GB on a Mac Mini mid 2012.

So, I just did an experiment to isolate the problem and got a trial license for 3.1 Pro. LABS worked.

I then disposed of the Pro license, rebooted and opened the same file with Elements. Now LABS was automagically fine.

It does seem like this may have something to do with eLC, after all.

Thank you for all who tried to help!

Glad it’s working!

I just downloaded the LABS AutoHarp instrument and ran Maintenance on the Licenser, and whereas in Dorico Play my Synchron Player will show earlier instruments like the Epic Orch, it will not give me access to the LABS instruments.

What is most perplexing is that Cubase will show me those instruments in the Synchron “picker,” but not Dorico.

Any ideas?
Dorico Diagnostics.zip (2.0 MB)

EDIT: I have since added LABS to the VST 2 Allowed list, cleared the Audio Engine, rebooted twice, rerun the Licenser through the Maintain cycle and even tried to point the VST2 source to drive G: (where the sound files are, but not the VST2 dll).

Still no luck.

I’m a little confused here as Synchron and Epic Orchestra are VSL and LABS is Spitfire. Are you trying to load LABS into VEPro? Or just into Dorico? It seems to work fine in Dorico for me anyway.

1 Like

That was the solution: I selected the wrong player (facepalm!).

Fred, many thanks. As you can probably tell I am way more inexperienced with the Cubase, DAW-style libraries than I am with Dorico itself.

1 Like

Hi Derrek,

LABS is its own VST. EO etc are loaded within the Synchron Player VST. So LABS wouldn’t show as a choice to load from within Synchron Player. It’s possible that you may not see LABS within Dorico’s Play choice. Unlikely, but you can check if LABS is allowed/(white listed) from Play preferences.

Alex