Split keyboard for Chord Pads and lead

I thought this would be easy, but apparently not.

I was enjoying noodling around with the new Chord Pads in C13 and it occurred to me it should be possible to set up the Chord Pad to work one track and split the keyboard to send the MIDI to another track. Seemed like an obvious thing to do, essentially recreating what I used to do back in the day on my Casio keyboard into the Atari ST(!) - one finger chord accompaniment while playing a melody.

I tried a MIDI transform on the tracks but that didn’t work, presumably because the transform happens after the chord input.

I tried using the obvious thing that appears in routing of setting the Routing to Chord Pads on one track and the keyboard on another.

The settings I’ve thought of all seem to want to route the chord pad output to any track. I must have missed a trick.

Double check which inputs you’ve included and omitted in All MIDI Inputs


How did you set it up, please?

I’m out with the grandkids so not able to check the answer.

In C13, the input transform has moved under Routing in the inspector, it was right at the top of the inspector in C12. The split is simple enough, enable the input transform from the buttons that appear from the squiggly button, then go to the editor. On the editor set up, on one track throw away input using the obvious midi preset as a starting point, changing the action to filter.

This works fine for a simple keyboard split. I need to review what happens with the chord pad.

I seem to have discarded my reply.

The setup requires checking a few settings on the ChordPad. At the top left there is an icon that looks like a power button. The tooltip explains it is a send all option, so obviously need this off, then in the track routing of the inspector ensure only those tracks you want the chord pad to trigger have the Chord Pads set as input routing.

Secondly at the top left there are a couple of setups - ChordPad display settings, I set this up to have an octave of chord pads (12) starting at C. Then on the ChordPad Remote Settings (the button that looks like a MIDI DIN plug) Set the Pad Remote range start and end (which I set to C1 to B1).

Together with the Input Transformers set to discard out of range notes for the accompaniment and the melody tracks, should be good to go. If you are using Groove Agent as a drum machine, a good idea to set the input to not connected.

The Chord Pads MIDI thru option may help you too, as rather than you filtering out the higher notes for the track which is controlled via Chord Pad, toggling this will simply prevent them from playing and limit only chords to play.

I think it’s called MIDI thru. Something like that! :slight_smile:

Edit: Just checked manual, it’s ‘Filter Notes’ option in the player you have selected:

It’s almost like Steinberg have thought it through :smiley:

That’s a much cleaner solution for the accompaniment track.