SSL UF8, Mackie and Remote Control Editor

So, I have the SSL UF8 controller, but want to edit the layout of plugin parameters since the order in which they appear don’t make much sense.

As I understand, the SSL is set up with the Mackie Control protocol. And unless I am very mistaken that corresponds to the System 5-MC in the editor.

Still, making a System 5-MC layer in the editor and putting all the parameters in the desired order changes nothing on the SSL controller. I’ve only tried one plugin so far - FabFilter Q3.

As far as I can tell Steinberg claims it to be compatible with any controller using the Mackie protocol.

Any suggestions?

Hi,

Sorry, I don’t know the SSL device.

On the original Mackie Control hardware, you press a specific button, which switches the V-Pots from controlling Pan to controlling the plug-ins’ parameters.

Yes, same on the SSL. The various parameters are then spread across the V-pots. But not always in a workflow friendly order. So that’s what I am aiming to change. And the editor is supposed to do that. But so far I am unable to see the changes reflected on the SSL… :unamused:

1 Like

For MCU parameters I go to the Remote Control Editor via the plugin menu as so:-

You can create pages and setup the 8 letter labels to it appears on screen nicer than the standard labels, The standard layout mode is fine in my experience - never touched System 5-MC.

Just remember to apply at the top right to save the changes. Sometimes you may have to reload the instrument or flick through the pages on your hardware to see the updated parameters.

Note: If you map any buttons or toggles on the plugin(s), just keep an eye on the knob type, you need to make sure that ‘standard’ is selected or buttons don’t always work in my experience:-
image

1 Like

Thank you. I’ve tried this, but probably doing something wrong. What brand and model controller are you using?

I use the Mackie protocol for about 4 differing controllers - it doesn’t matter what the controller is, as they’re all routing back to this concept if you’re going through that protocol/device in studio setup.

What is going wrong for you? Are you 100% in the Mackie mode and the workflow matches this document? :-

Page 35 for inserts, and Page 41 for instruments.

Obviously the buttons on your hardware may be setup differently to a real MCU with Steinberg overlay. But on the UF8 you have the menus at the top, such as VST Instrument, and FX Inserts which are the equivalents of what would be pressed on an original MCU.

Within the FX Insert control button is where the mappings should pick up on the orders you create within Cubase. i.e.

Thanks for getting back to me again. I was about to do a few screenshots of my setup when noticing it’s the way I want it now. Maybe my mistake has been not restarting Cubase after making changes, because now the changes are being reflected.

Oh perhaps because the UF8 has an extra layer with the SSL software that ‘prettifies’ the MCU integration - you may need to restart for it to refresh back to your controller. That would make some sense if it’s caching data of some sort for efficiency.

Yeah, that could also be it. :slightly_smiling_face: