STABILITY ISSUES: Yamaha Steinberg USB Driver (ASIO)

/rant on

This has been going on since I have purchased my UR44 about 6 months ago (I think), but I have just dealt with it and it is getting annoying.

The Yamaha Steinberg USB Driver (ASIO) just unconnects for some reason. Leaving the UR44 white LED blinking. All while the computer DAW system is up, running and stable.

The only way I can reestablish connection is to literally power down the computer and restart, not rebooting, power off and restart.

I have spent months collecting data to see if I can garner a relationship of events that trigger this problem, so I can possible adjust my work flow to prevent it from happening as a work around (e.g., stand on left foot, put right hand in air, press record)…but to no avail…no patterns. It just keeps happening, randomly, no rhyme or reason…very annoying.

Keep in mind, I will use my Axe-Fx III as the ASIO audio card in a pinch during recording for guitar and MIDI keyboards (MIDI through a MOTU Microlite) and have never had ONE single problem. But I have to use the UR44 for phantom power microphones (C1, Rodes) for vocals. I like the UR44, but this ASIO driver thing is becoming very problematic.

Please be aware, that I have already screened and changed my computer for a DAW system e.g., BIOS parameters, computer and USB power parameters, etc. (there is a ton of info on how to do this from Steinberg, Sweetwater, etc.) So my system is optimized for an audio studio DAW. Also, I have previously used Sony ACID, n-Track, and Reaper with this computer and other sound cards with absolutely NO problems (latency has varied however). I have last year had to change work flow and system and elected to go with Steinberg/Cubase and ALL is very well EXCEPT this ASIO problem. Maybe I should have chosen to go the ProTools route. I don’t know.

  1. Is this diver instability situation a known problem in the community?

  2. If you are having a problem like this, what have you done to correct the situation?

  3. I am currently using version 1.10.2 of the problem driver (came with UR44), but there is an update to version 2.0.3 out there. I am not entirely convinced that updating this driver will solve the problem, and I am NOT going to do that unless I have a sure fire way to roll back that update (which has caused other problems before in similar situations). I am not keen on using Windows Restore Point, because restoring has caused other problems in similar situations (that’s actually a last resort in a Windows environment), and doing a mirror image for this specific problem is overkill (Although I maintain mirror imaging). It would be nice if I knew of a simple procedure such as a) locate and save this file b) copy the new file to this location c) test d) if it doesn’t work, copy the original file back to this location and you are exactly back to where you were. Does anyone know of a SURE FIRE way to preserve what I have now, test the 2.0.3 update and then revert CLEANLY if it doesn’t work.

UR44 has served and is serving me well…high quality…just works…but this driver situation is getting out of hand.

Thank you, in advance, for patience, time and sharing of solution-oriented information.

/rant off

I’ve got the same issue with ur12. Even when I’m doing nothing on the compu, Cubase isn’t open, then I hear that da-dunk! Sometime it’ll do it 3 or 4 times in a row!
I’m also struggling with eLCC issues, Cubase 10.5 Artist freezes up, crashes, ba-dunk!
HP issue? USB issue?

I can save you some troubleshooting time. No guaranty. I run an extremely stable system and guard it as such. I develop hardware, firmware and various types of software. I run several ASIO hw/sw systems on this particular computer, including Fractal Audio. I have absolutely no issues at all. I use the UR44 for mics. Your problem is not a USB or system incompatibility problem due to quirks in your hw/sw. IMHO. Based on what I know and my diags, I suspect it is a memory leak in the Yamaha driver when maintenance calls are made by the operating system. I thought it was an ASIO buffer overflow critical error that went uncaught by the driver, but it happens when the ASIO is not being used and is idle. Steinberg refuses to answer my support requests except to tell me to upgrade to the new version. My research has shown in doing so will completely break the functionality of the UR44 / driver / DAW system. I should mention that I use several DAWs, including Cubase. The driver death is common across all my DAWs. One individual reportedly reverted back to a previous version of the driver…I think it was 14…and fixed his issue. I cannot find this older version. I have pretty much just accepted Steinberg’s lack of response as an indication and moved on, which is typical hw/sw dev support for products. They are supporting a third party driver, and are making revenue on non-problematic systems…a sound business decision. The UR44 is fantastic, but the Yamaha ASIO driver has serious issies. Good luck.

1 Like

Hi Burksfamly
Thanks for your input.
I found stepping back or rolling back to the e-licenser 6.11.10.2266 helped a lot with getting the program running. Steinberg called it an update, then I noticed it was an older version.
There is still an issue with e-licenser and the UR12 on start up of Cubase, errors, can’t find etc… but at least the program will open and I can work on a project!
Random ba-dunks as I call them.
I may be just on the computer, not even using Cubase, and I will hear several ba-dunks, ups and downs, disconnecting and reconnecting. The mouse, being usb also freezes. I use my UR12 for also all my audio while on the computer.
I will continue and thanks again for your input!

I think you’re right.
New UR22c here with audio dropouts. Not for much longer though as it’s going back.
Disappointed and annoyed as it has more features than most at this price range. External power option, midi I/O, daw/input mix dial.
Seems like it’s an unfinished product.

I would be inclined to check your internal and external USB connections(depending on what port you are using) and cabling, along with power.
You might also try buying a separate PCI-E USB card as perhaps the drivers and chipsets are having a bad day with each other (I’ve had this happen with an older PC and newer OS+drivers and just grabbed a newer PCIE USB card).

Thanks.
Thinking supplied usb cable here. Have just cleaned the plugs with electrical cleaner and so far no dropouts in usb 3.0 mode.
Fingers crossed.

i may have to put this shit in the trash bin and buy something decent. frustrating

Well I’m having some very weird problems with my UR22 MKII. It’s been working absolutely fine for years, the last couple of which have been with Windows 10. This week, however, I received a new PC… installed Cubase and the Yamaha drivers but Cubase cannot see the UR22. Checking in Device Manager I could see the UR22 but then it suddenly disappeared! After a few seconds it popped into view again and then after a further few seconds it disappeared. That cycle just continues, with the UR22 literally ‘coming and going’!

So, what to do next because at the moment I’m really stumped? Tried older drivers… no go… tried using a USB 3 port… no go…

Should I be looking at a different interface? Seems a shame as there’s nothing wrong with this device. Are there any alternative drives out there that I could try?

Clutching at straws now

1 Like

https://forums.acoustica.com/viewtopic.php?f=4&t=26797

Pls check a stability issue with mixcraft 9.0 Daw

For random disconnections you might try getting the motherboard chooser drivers directly from the manufacturer. For example, I have an Asus motherboard which has an amd 970 chipset. I went to the AMD website and got the chipset drivers myself and it seemed to solve any usb issues I had with things. The ones windows installed automatically are usually out of date.

Thank you for your reply.

Fortunately my issue just corrected itself… somehow… I have no idea how… maybe a Windows update. Whatever was causing the problem has not reared its ugly ahead again and so far everything has been stable.

I´m having a similar problem.

About 1 out of 5 times I start Cubase the PC freezes. I get a popup saying that the UR12 was disconncted, prompted to choose ASIO4All, regular or Yamaha/Steinberg drivers. But I cannot, because the PC is completely frosen, can´t move the mouse cursor, cant use keyboard menys, can´t shut down with PC power button etc… The only way is to disconnect the power cord.

I´m using the Cubase LE that came with the UR12, Win 10 64-bit. Lenovo staionary PC.

It is very annoying and Steinberg support can´t help. I was going to try and google a solution, but obviously “burkfamly” knows much more than I do `bout computers and he/she seems to have tried everything I could have come up with.

I sympathise with you issues… nothing worse than trying to track down intermittent problems. One thing that might help with the pc freezing, if you have a wireless keyboard and/or mouse is to move the transmitter to another USB port. I’ve found if I plug anything into the USB port directly next to my Mouse transmitter then the mouse will freeze.

Literally having this issue atm and its driving me mad. I tried to remove and re-add the drivers, uninstalled and reinstalled sonarworks sound ID but for some reason the Yamaha driver keeps disappearing and reappearing from the output selection. Honestly this might be more on sonarworks, but I thought it was interesting you had the same issue with Cubase