Staff Hiding Problem - Clefs

I want to have a tenor trombone part use tenor clef as its primary clef. (This is standard in many orchestral scores.) There is no option to use tenor clef as the default clef for trombone when I add the instrument, so I just changed the clef at the first bar of the score. However, if I use the Hide Empty Staves option, this prevents the trombone from hiding on the first system, even if the trombone does not play at all on this system; the only thing inputed on the part is the tenor clef.

Is there a way to fix this so that the part will properly hide, but the tenor clef will still be in place when the trombone first enters?

I don’t want to just have a clef change at the beginning of the first system that uses the trombone, as that would have a clef change in the middle of rests in the trombone part, rather than the part having a tenor clef from the start.

The only option, in light of your ending clause, would be to pick an instrument that uses tenor clef by default and rename it. If playback is an issue you could then reassign the proper sound.

As a last resort, you may edit the instruments.xml file and make the default clef tenor. Starting at line 77500 … change clef.bass into clef.tenor… save and restart D.

	<clefIDsForEachStave array="true">

I can’t find any instruments that use tenor clef by default.

How do I find this file on Mac?

I found it!

I don’t want to edit the XML file, and there are no instruments that use tenor clef by default. How do I solve this issue?

If you change the clef at the beginning of the music, it does work… Unless you need to hide that staff and this prevents you to do it…

I need to hide that staff, and this prevents the staff from hiding.

I guess you could import a musicxml file that contains an instrument that is set to use tenor clef by default. That would depend on you (or somebody friendly) having access to another piece of notation software.

Pianoleo is right; this method provides various options to “hack” Dorico. This is how users were able to get pianos with 3 staves, for instance. I bet that would work (haven’t tried it though).

You don’t need another app. You can export a Trombone with a Tenor C clef as XML from Dorico, and then import it back into existing projects.
The clef will be part of the instrument definition, and so will not stop hiding.

Here’s an XML file.

Obviously, it will import as a new Flow, but you can make sure you’ve got the instrument selected in other Flows, and then delete the new flow. (1.03 KB)

When I imported the file into an existing project, the tenor clef was not part of the instrument definition. It was deletable, leaving a bass clef. When set as playing in other flows, it defaults to bass clef. Tenor clef is only part of the instrument definition when opening the file as is, and not importing it to an existing project.

Ah. You’re right. Sorry. It works only importing as a new document, not into an existing one. I suppose at worst, you could import your existing flow into a new document featuring the trombone…!

I’ll try another method, that’s a bit harder to create, but easier to use.

I still do not have a solution to this problem. It has been extremely bothersome for months. Does anyone know of a solution to this?

Note: This is the same person who made the original post. The forum site glitched and locked me out of my original account.

If you zip up your project and attach it here, I’ll fix it by hand for you. There’s no feature in the software at the moment that will allow you to fix this directly. (853 KB)

Here you go. (924 KB)