Staff labels in score

Here’s my second question today:

I read that, for 2.2:

Note: “Staff labels do not show all instruments held by players, for example, in the staff label for the first system. You should include a comprehensive instrumentation list that shows any doubling at the front of your score.”

So if I have a staff for Flute 2 & Picc., I can change that player’s name (and it will show like that) at the Players list in Setup:
Screenshot 2020-06-14 at 20.00.33.png
However, according to the note above only the name that I give to the first instrument that plays will appear at the beginning of the score (Flute 2 in my case).

It is very normal to have both the main and the doubling instruments specified in the staff label for the first system (besides the “list at the front of the score”). Here’s an example from Hal Leonard:

Is there a way to do that in Dorico in 3.5? Could the name of the player “Flute 2/Picc.” appear as a staff label?

Thank you

At the moment there’s no automatic option for this, but you can do it for yourself (in either Dorico 2.2 or a later version, using the Edit Names dialog. Edit the full name to include the name of the doubled instrument.

Thank you for your response, Daniel.

So, if I understand well, in the case of doubling instruments on one staff, the Edit Names dialog will do this:

-The Full name of one of the two instruments (the main one, in this case Flute) will be the staff label for the first system, containing, if you want, the name of both instruments, Flute AND Picc: “Flute2/Picc.”

-The Short name of this main instrument (Flute) will be used for subsequent systems, and also to indicate changes of instruments in the music (To Fl., Fl.)

-The Full name of the secondary instrument (in this case Piccolo) won’t appear anywhere, unless it was the first one to play some music. In such a case it will appear in the first system, instead of the Flute full name, Therefore, I should edit its name to “Flute2/Picc.” as well.

-The Short name of this secondary instrument (Piccolo) will be used for subsequent systems, and also to indicate changes of instruments in the music (To Picc., Picc.)

It would perhaps be a good idea to explain it like this in the manual? In any case, I think it would be simpler that the staff label for the first system is named the same way you name your player in the Players list, regardless of how many instruments that player plays.

If I am not mistaken, the player’s name is already retained by default as the Layout name, the name that is displayed on the first page of every instrumental part. This behavior can be overriden if you manually change the Layout name (right panel in Setup mode) though.

The Player column vs the Layout column is a concept still a bit confusing to me, but in any case, I have tried to edit the name of a player in the Layout, and it didn’t change the corresponding staff label in the score. I think the only place to achieve that is the Edit Names dialog. And it works the way I wrote above, for what I’ve seen.

Yes, you are right. I simply told you something quite different : the player’s name (when you create a player) is the name used by default to name the corresponding layout. But it’s never used as staff label, you’re right.

An interesting update to my post:

Working on the Oboe 2/EH staff I have encountered the scenario in which the first note in the music is played by the doubler, the EH.

So I have edited the Full name of the EH instrument in Edit Names so that the staff label in Page mode reads “Oboe2/English Horn”. No other way to achieve that.

But of course… since the first note is played by the EH, Dorico sees no reason to specify “to EH” or “EH” inside the staff, right before the note. It would no be a problem if the first note was played by Oboe 2, because it is understood that Oboe 2 is the main instrument. And labeling the staff a reverse “English Horn/Oboe 2”, so as to justify that the first note appearing is played by EH with no other warning, would be strange.

So I’ll have to manually add a text saying “to EH” right on the first bar, if I want to avoid that the player attempts playing that note with the oboe.

All this would be easily solved if the Player name, not the instrument name, translated directly as the label of the staff. I think.

Go to Layout Options / Players / Instrument Changes / Show instrument change label at start of flow.

Ah! Very good, thanks! At least that’s solved.

Now I’m working on Clarinets and I have edited their names to, for example: B♭ Clarinet 1 (I found the ♭ in the Academico character map):

However, for some reason the tail "in B♭ " won’t disappear from the name. I don’t know where to edit that, and I want the key to appear in the beginning, not at the end…
Screenshot 2020-06-15 at 21.06.57.png
Is there a hidden menu item for that?


It’s in the same dialog window, at the bottom:
Schermafbeelding 2020-06-15 om 21.31.19.png
Set the option to ‘never’, or alternatively, change Layout options.
In fact, you don’t need to specify the B♭ part in the name itself. In Layout options > Staves and Systems > Staff Labels, you can select Position of instrument pitch in full staff labels > Start. That will take care of it.

Great help! Thank you

Wait… @Rob, “Show instrument change label at start of flow” solved the problem in the score, but the part doesn’t show the change. Am I missing something?

Did you change the setting for the part layout separately? Each layout has its own layout options.

Found it, thank you. That got me, I didn’t see it had to be done to each layout separately.

One does not have to change layout options separately. One can select a range of layouts in the right column via SHIFT+Click or CTRL/CMD+Click and make the same change(s) to the multiple layouts simultaneously.

That’s very useful info. Thank you!

There even are two special buttons to select all full-scores and all parts. The devs have put tremendous intelligence in there.

This may seem unrelated, but it’s part of the same process. For some reason when I imported the music as XML, Dorico/NP assigned a Horn “in B flat” to the Horn parts. I need to change the instrument to a Horn in F, not only for staff labeling purposes, but also so that the transposition is correct in the part. The sound won’t change much. However, when I click on Change Instrument, no window opens, nothing happens. All other options on the list, Edit Names, etc. work fine…

I have rebooted just in case, but no luck.
Screenshot 2020-06-17 at 17.53.19.png

Changing instruments for them to be correctly recognized is the usual path. Change instrument not working is a real issue, that I have not had yet, but clearly not the expected behavior. You can always create a new player (Horn in F) and copy the music from the former… But less elegant.

Oh… real issue meaning I’m not the only one to experience that?

Yes, I imagined the workaround would be that, but as you said not really elegant. Clicking on a dead dropdown menu item feels weird. might as well get removed.

Unless there’s a hidden option somewhere I’d need to activate first…