Staff Spacing Problem

I am having trouble getting all my staves onto one page. I have gone through the manual but can’t figure out what I am doing wrong. I know it is probably simple! Basically, I trying to get the two staves on page two onto the bottom of page one and have created enough space for them to fit. I just wonder why they don’t automatically move onto page one when there is space? Attachment.
Anastasia.dorico.zip (438 KB)

There are several Layout Options settings you can change which will help, like the distances between systems, page margins, music frame margins, turning off flow headers, (rastral) space size, etc. Here’s your file. I changed several of these settings, perhaps even more than necessary, removed the page overrides, set the header not to show, reduced the space size very slightly and removed the system break. Fits nicely onto one page without even having to force the issue manually.
Anastasia.dorico.zip (437 KB)

That is brilliant. Many thanks Vaughan. I’d adjusted the the staves using the staff spacing tool in Engrave mode but couldn’t work out how to get page 2 staves to immediately follow the staves on page 1. This presumably was the page override removal?

Actually you’d moved the frames around and changed their format in the pages themselves. This causes page overrides. I also removed the manual changes in the staff positions and changed the distance between systems from 10 to 5 spaces.

I hope this is the correct threat for this. I have written a lead sheet that should fit onto one page. It is 32 bars long with an eighth note pickup. I want the first four bars with the pickup on the first line (or staff as the Dorico terminology puts it). As I do this the program insists on placing the last four bars on a second page, even when I adjust the spacing or the staves. I then used the ‘two-pages-into-one’ button to get all the music onto one page, but the program then overrode the change I had made to have the first four bars and the pickup on one staff, even though the music fits better with my change. When I corrected that, it sent the last four bars back onto a second, and unnecessary second page. How do I fix this?

Excuse my typo, I meant “correct thread”

This is most like an unrelated thread, but never mind.

What the “Make Into” do is add two Breaks and set the first Break’s “wait for next” property.
Having used “Make Into System” for the first four bars, select the purple System Break flag at the start of the page (it’s a signpost, so if it’s not visible you need to turn System Break and Frame Break signposts on from View > Signposts).
In the properties panel, change the Break Type from System Break to Frame Break.
Then in the Engrave mode properties panel, turn on “Wait for next Frame Break” in addition to “Wait for next System Break”.

Dorico will now keep forcing music onto that one page, until you add another Frame Break.

Pianoleo,

Thank you for your advice, but I am still have trouble here. I need to have the first four bars plus the pickup’s partial measure on the first line, or in the first system. This is common practice for a lead sheet. I don’t know if this is how to send you the file, but I’ll try it. You Or Me.dorico.zip

Paul, the project didn’t attach. Please check that the zip file is less than 2MB in size, then try attaching it again. If it’s not less than 2MB in size, open the project, do FIle > Save As to save it as a copy, then in Play > Playback Template choose ‘Silence’ and click Apply and Close, then save the project, and zip up that version to attach it here.

Thanks Daniel. I did not understand how to attach the file. This should work.
You Or Me.dorico.zip (337 KB)

This is a little bug, and one which we’ve had reported before. When you do Make Into System, if there’s an existing frame break at the start of the affected selection, Dorico is supposed to maintain the state of the “Wait for next frame break” property on that frame break, which is what is forcing the music to all fit into a single page. However, due to a little bug, it loses track of that “Wait for next frame break” property when it creates the new system break. So to work around the problem for now, after you do Make Into System, select the new system break signpost at the beginning of the flow, and activate the ‘Wait for next frame break’ property. That will put things back as they should be.

I am sorry Daniel, but none of this seems to work. No matter what I do the program will not put the first four bars, along with the eight note pickup on the same line, or in the same system, as you are calling it. (I have always thought of an entire lead sheet as one system, so this is a bit confusing to me). In addition I can find no mention of the “Wait for the next system” property, and have no clue as to where I would find it. I am now back to a lead sheet that should be on one page, but spreads to two. When I put the system break at the beginning of the flow it canceled the Frame break. Did you mean that there should be both a system and frame break at the beginning?

It should be this simple, Paul:

Thank you. It would help if there were better documentation of this in the Dorico help. Just a suggestion for future upgrades.

https://steinberg.help/dorico/v1/en/dorico/topics/engrave_mode/engrave_mode_systems_making_from_selection_t.html

I found this by googling “Dorico wait for next system.” Other related search terms return similar results.