Standardprogramm 32bit/64bit

Hallo,

bisweilen hatte ich eine Projektdatei geöffnet und diese öffnete sich mit der Cubase 64bit Anwendung.

Seit gestern öffnete sich nun die Projektdatei mit der 32bit Anwendung.

Was kann da schiefgelaufen sein?

Und vorallendingen wie kann ich es nun einstellen, sodass sich Projektdateien mit der 64bit Anwendung öffnen?


Viele Grüße!

Ich gehe davon aus, dass Du die Projektdateien bspw. auf dem Desktop hast, und du darauf Doppelklickst, und die C7-Anwendung startet.

Hast Du vor kurzem die C7 32 Bit Anwendung installiert?
Wenn ja, dann ist es leider so, dass die C7 64 -Anwendung sich nicht mehr mit “Öffnen mit…”-Dialog (rechte Maustaste auf cpr-File) öffnen lässt. Bei mir ist da nur noch die C7 32 Bit Anwendung hinterlegt.

Diesen Bug habe ich dem Steinbergsupport schon mitgeteilt.
Da hilft nur noch die richtige Cubase-Version vorher zu öffnen.

Dies ist kein Bug, das ist ein Feature von Windows.

Wenn man eine Software installiert, dann kann diese die Extension im Windows registrieren, dass wenn man eine Datei doppelkickt, diese mit der installierten Software gestartet wird.

Um die gewünschte Funktionsweise Windows wieder “beizubringen” müsst ihr nur auf den “Öffnen mit…”-Befehl (Rechte Maustaste auf die CPR-Datei) klicken und dort entweder “andere Programme” auswählen oder, wenn es dort nicht zu finden ist, auf “durchsuchen” klicken und euch durch die Festplatte zu eurer entsprechenden Cubase-Installation durchforsten und die Cubase EXE-Datei auswählen. (Ich habe hier mal den Weg für Windows 7 beschrieben)

Danach müsste alles wieder funktionieren.

Hatten wir zwei nich auch schon drüber geredet?

http://www.youtube.com/watch?v=aAhdVkgklFE

Genau das habe ich mehrmals probiert, funktioniert aber nicht.
Die vorherigen Versionen von Cubase legten von sich aus schon zwei Auswahlmöglichkeiten an.
Wenn man das mit Cubase 7 machen möchte, auch nachträglich manuell, funktioniert das nicht.
Das Thema habe ich an Helge abgegeben, das ist kein Windows Problem.

Ja, klar :mrgreen:
Nur dieser Workaround ist nicht meins.
Es soll so funktionieren, wie es bei anderer SW auch funktioniert.
Kann sich mal Marcus von Steinberg dazu äußern, ob daran gearbeitet wird?

Hallo whitealbum (und der Rest),

ich habe von Anfang an beide Anwendungen installiert; also nicht erst nachträglich.

Wie whitealbum schon treffend erklärt hat, kommt man mit dem Procedere: Dialog “Öffnen mit…” (jedenfalls unter Windows 8) nicht weiter.

Was mich aber immernoch wurmt, ist die Tatsache dass es vorgestern noch mit der 64bit-Variante funktionierte und gestern nicht mehr. Hab auch schon beide Cubase Anwendungen neu installiert. Zunächst mit Erfolg (Cubase 7.0.0), dann aber nach dem aufspielen des Update Cubase 7.0.1 wieder das gleiche Spiel (32bit öffnet Projektdatei, nicht 64bit).

Viele Grüße!

P.s.: Status: Problem besteht weiterhin. Übrigens zum Videotip von djkey: das Video hilft mir leider nicht weiter.

+1

Wäre nett wenn sich Marcus dazu äußern würde.


Viele Grüße

Hi,

leider handelt es sich hier um einen Bug unter Windows, welches seit (meines Wissens nach) Windows Vista vorliegt.

Die Zuweisung des Standard- Programmes übernimmt das Betriebsystem und kann dort auch Versions-Spezifisch eingestellt werden. allerdings funktioniert das nur, wenn man von Cubase 5 auf Cubase 7 ändert. Es funktioniert leider nicht bei Cubase 6 in 32-bit oder Cubase 6 64-bit. In diesem Fall wird Cubase dann beim Doppel Klick auf eine Projekt-Datei Cubase als 32-bit Version öffnen.

Diese Problematik liegt auch bei anderen Dateien, wie zum Beispiel Video- Dateien vor, wenn man verschiedene Video- Player installiert hat, bei unterschiedlichen PDF- Readern oder auch bei Brenn- Programmen und ISOs.

Ich habe trotzdem die Sache noch einmal an unsere Projektplaner weitergeleitet, allerdings sind die Chance sehr gering das sich da Neuigkeiten in naher Zukunft ergeben.


Viele Grüße

Marcus

Hallo,

vielen Dank Marcus für die ausführliche Antwort.

Würde es helfen, Cubase und sammt aller anderen Anwendungen von Steinberg zu deinstallieren und wieder neu zu installieren?


Viele Grüße!

P.s.: Die Frage stelle ich, weil bei einer vorherigen Deinstallation, beim Draufspielen von Cubase 7.0.0 die Projekte mit der 64bit-Anwendung gestartet werden konnten und beim Installieren vom Cubase 7.0.1 Update plötzlich wieder mit der 32bit-Anwendung gestartet wurden.

Hi Polyplus,

es gibt eine Möglichkeit in der Registry das auch zu ändern, unter XP ging das wesentlich einfacher.

Das Problem liegt wie gesagt seit Windows Vista vor, da man dort die Möglichkeit eingeschränkt/verändert hat, File- Extensions mit Standard- Programmen zu öffnen.

Ich habe in verschiedenen Microsoft Support Foren (identische) Probleme mit anderen File- Extensions gefunden.

Leider…

Aber wie schon gesagt, ich habe das mal weitergeleitet…

Auch von mir ein Danke schön für die Info.
DrMax hat diese Möglichkeit ja auch aufgezeigt, ist aber leider nicht dauerhaft.
Fein, das Du das weitergeleitet hast, ggf. gibt es ja eine Möglichkeit.