Stave lines missing in imported score

Hi, strange issue, when importing Music XML, compressed or uncompressed, from Sibelius, one score has missing stave lines. Other scores import fine.

Any way to fix this?

I’m not sure how to upload a pic - but all the notes are present, all articulations, just no 5-line staff lines appear.

Thanks,

Mike

Not sure why it happened but have you fixed it? Does adding a time sig fix it?

I suspect the issue is that the MusicXML file itself specifies that the part in question should have no stave lines. If you can zip up and attach the MusicXML file, we should be able to help.

I’m terribly sorry I can’t seem to understand how to attach a file here…I’ve created a snippet of the problem and am happy to post if I can figure it out; a search on how to attach did not give results.

I can add this: the Sibelius score had a cover page in front, and I suspect that’s throwing everything off…

Thanks,

Mike

The little arrow icon (Upload) will let you choose a file to attach. Size limit is 4mb.

test.dorico (779.1 KB)

Many thanks; MusicXML attached.

Mike

I had a quick look and although I’m not sure what caused it, I found that if I changed the instrument to the same instrument (eg click the 3 dots on the piccolo instrument, change instrument, select piccolo) then the stave appears. I tried a few of them… same result :slight_smile:

1 Like

I opened your Dorico file and exported the Piccolo as an XML. Upon opening, I see it has this bit of code:
0line

I assume that was a result of the original Sibelius export. You could export from Sib, then open the XML file and change that line if needed before importing into Dorico.

1 Like

Hi Fred, many thanks, I really appreciate you taking time to figure this out. Helps me out a lot, as I wasn’t sure how to proceed.

Also many thanks to Daniel, who tirelessly supports everyone. I hope you have time for your wife and kids lol.

Thank-you everyone.

Mike

2 Likes