Steinberg Activation Manager "Sign In" button not working

Trying to sign in to SAM but pressing the “Sign In” button does not open browser (Chrome)

  • have tried Edge and Explorer browsers
  • I’ve allowed SAM app through Firewall
  • I’ve set Chrome to allow pop-ups and redirects (not sure if this has anything to do with it)

Can you please help me fix this? Thanks.

2 Likes

Same exact problem. I recently purchased Cubase 12 Pro and downloaded all the software directly so that I could avoid running faulty Steinberg Download Assistant (which has the same problem, namely, a useless sign-in button) and now the activation manager is messed up and I’m stuck with four hours wasted on troubleshooting, 600 dollars gone, and no software activation.

Which version of Windows are you using?

Windows 8.1

I’m using Windows 10

Cubase 12 requires 64-bit Windows 10 Version 21H2 (or higher), 64-bit Windows 11 Version 21H2 (or higher)

Which build of Windows 10? Is it 64-bit Windows 10 Version 21H2 (or higher), 64-bit Windows 11 Version 21H2 (or higher)

64-bit Windows 10 21H2 is the build of my computer so I’m not sure why it’s having issues

I met this too! But I guess there is nothing wrong with you software or sttings but extremely serious delay. I first tried at around 7:00 p.m., now it’s 12:00 p.m. and everything just turn right even without reconnecting net or restart computer. (Well maybe it’s just my personal experience but you can have a try )

HI Activation manager “Sign In” button is not working for me then I cant launch the Cubase 12le

I’m having the exact same problem. When I turn on the activation manager and click the sign in button nothing happens. When I use the download manager it works fine but for some reason this doesn’t. I’ve cleared my cache, set Microsoft Edge as the default, and disabled my firewall. Nothing has worked.