Steinberg Download-Assistant and Activation Manager Not able to Connect

Hi there,

Steinberg Download-Assistant and Activation Manager stop working in my OFFICE enviroment. It worked few months ago and one day it just saying not able to connect.

This is a pretty awkward situation for me and all my recent purchase (Spectralayers and Halion) are not able to registered.

On Antivirus/Firewall:
I am not able to do any thing with the antivirus/firewall settings, those things are strictly built-in my computer, and even I did all I can with my computer settings, there is also another firewall that’s built from the company level for privacy reasons.

On re-install:
I also tried deleting and re-installed these two application and doesn’t seem to work.

Are there any other way that I can do to install and register my product in this situation?

Btw, all other software updating portals like Ouput Hub, Arturia Software Center, NI Access, UA Connect, Plugin-Alliance, UVI portal can work perfectly in my computer.

Kinds
Josh

If an AntiVirus, Firewall App or the like would prevent access to the Internet for the Activation Manger or the Download Assistant, it would look something like this:

It’s kind of like this, and I am not able to login to my account.

Are you on a company network? Is it possible that the Administrator has blocked the steinberg.net web address? :smiling_imp:

Right, that reminded me of the white list system in the company, will look into it. Thanks

Hi, if you have the possibility to allow certain servers and ports, please refer to the list you can find on our webiste: https://helpcenter.steinberg.de/hc/en-us/articles/360020415859-Servers-and-ports-used-by-Steinberg-applications

1 Like

Hey, download assitant show this message when opening.
Steinberg Download Assistant Error

I did communicate with the IT from the company and their test result is that

  • There are no interception occurs while using Download Assitant and Activation app.
  • There are also no restriction that sets to block the servers/ports that you listed.

Is it possible that steinberg restrict the access from the company network?

If you are running a version of SDA prior to 1.35 you will need to download a newer version from here Steinberg Download Assistant | Steinberg - it’s possible that this is the cause of the error message.

Steinberg Download Assistant is already the latest version, and I tried re-install it, but doesn’t work