Steinberg download assistant can't start

I am having the same problem. Not using aria2 resulted in me having to click "save’ in my browser 114 times. There has to be a better way - say a single 31 gb download.

I am very disappointed that there hasn’t be more forthcoming solution from Steinberg about this.

If anyone still has this issue, in my situation it was a problem of a no longer existing path (which I used for the Windows Download quick link and as well used in SDA directly). I can only assume that either one of the facts makes SDA faill to launch.
I have not my D: path again available and SDA kan launch normally. It is a bit of a not so well programed application, since from my view it should be able to handle and point to local existing path. If it is an issue with Windows Download quick link “dead” path, it should better report this in the error message instead of throwing cryptical missleading messages.

Coder > review you app!

Hi,

Do I understand the reproduction of this issue is following, please?

  1. Install Steinberg Download Assistant (SDA).
  2. In the SDA set custom path where should be the files downloaded from SDA.
  3. Quit SDA.
  4. Delete your custom folder in Windows Explorer.
  5. Try to start SDA.

=> SDA doesn’t start.

If I follow these steps, the Steinberg Download Assistant resets to the default download folder and works normally.
Is there anything we are missing?

Hi, folks,
This solution worked for me:

I moved the files from:

C:\Program Files (x86)\Steinberg\Download Assistant\3rd Party\optional\aria2

to

C:\Program Files (x86)\Steinberg\Download Assistant\3rd-Party\aria2

and voilà, the application opens

I think the same would be possible for Mac users.

I hope works for you.

I just registered here to report what my solution was: In my case I had deleted the standard “Downloads” folder in Windows 10. As SDA “needs” that folder, it wouldn’t start. So I created the “Download” folder again, and the program would start.

Moving the Aria2 folder would also make SDA start (in fact that deactivates Aria2), but then I would have to download all the packages one by one in the browser and install them one by one - not an option.

3 Likes

After months using SDA without aria2, update 1.16.3 messed it up, I need it fully functioning to download a fresh version of Absolute 4. I’ve tried some suggestions from this topic. I even replaced aria2 with the GitHub package, 32 and 64bit. Nothing worked.

My solution (Windows):

(Steinberg Download Assistant not running…)

  • Run regedit from a command prompt in admin mode
  • Go to [HKEY_CURRENT_USER\Software\JavaSoft\Prefs\net\steinberg\elicenser\download]
  • Joyfully annihilate that [download] key with its subkeys

Just for the fun, my download (UNC) path “\QNAP-451_VMWin8\Steinberg” as stored by (now working) aria2 in the registry:

/////Q/N/A/P-451//_/V/M/Win8///Steinberg

What’s this?!

that thing worked for me about 1 year and then produced that same error code. Ever since it did not work. For some time there was a workaround deinstalling aria 2 options which made it work without some nice features but at least something.
Now with this new release it is as dead as a stone.
But for me one hint from a posting in this thread brought help. Also in my case it was the standard download folder that is needed by the Downloader. Once I restored that download folder, evrything was fine.
Hope I can help others with this, too.
To the software developer: Just let the program create a folder. Simple as that

1 Like



Thanks! This is what caused SDA to fail on my other computer. The “default” download location pointed to a directory that didn’t exist anymore. Once restored, it works as expected.

Now, speaking as a programmer by trade, this is a case of very bad programming on Steinbergs part. Quite unbelievable actually, that such a rookie mistake even got past initial peer reviews (assuming Steinberg even has those). Here’s a tip Steinberg, if an API call that queries Windows for a default path fails, ask the user where to place the downloads, or use a temporary directory and notify the user about it. This kind of error is completely recoverable.

Rant over. Here is a handy link on how to change the default download folder on Windows 10: https://www.howtogeek.com/273618/how-do-you-change-windows-default-download-path/ (if it’s not called “Downloads”, look for an icon with a blue arrow pointing down. In my case, it was called “Web”).

1 Like

Hi All,

I had an issue recently too with Steinberg Download Assistant.

I would try to launch but no errors for me. I would be stuck indefinitely to this startup pop up saying “Launching the Steinberg DOwnload Assistant…”

I tried re-installing etc, but no luck.

Worth mentioning that the default directory was not moved for me. It was intact but I had some time to launch this software so not sure what had intervened for this behaviour to come forward.

My solution was to use the .jar version of the SDA in program files, and worked like a charm. :slight_smile:

This was the same issue I had - this folder is required when you first launch SDA.

I started a new Win 10 install and had cleared out all the self-bloatware/folders/etc. that Windows creates, including this Downloads folder.

Many thanks for the solution, thought I’d bump this up to say to check your Windows/Users/youruusername folder for ‘Downloads’ as part of troubleshooting!!

1 Like

This issue is definitely caused by moving the default Downloads folder (using the MS technique described above as opposed to simply employing Del key in Windows Explorer!) after installing the Download Assistant … and then deleting the previous one.

When recreating the new folder (in the position required by Steinberg’s D.A. - that is, the location it was in when D.A. was initially installed), it is best to NOT delete the ‘incorrect’ one before doing so as this messes with the Windows-provided restoration process and prevents it from working.

Hope this helps…

this is another ISSUEW , again, I set here and wast fck ! time. last time was NVIDIA. I dont accapt to setit and twinckle and mess into, and fix into wondows files, and do al kinds of workaournd . What is it with this cubase. Oyou sure havetime to announce now things to sell ! Today suddenly to error massages poppo up, trying Assitant.