Steinberg download assistant can't start

It shows error"Error invoking method", “Failed to launch JVM”.

Hi,

Make sure Java is up to date on your system, please.

I have exactly the same problem:

Steinberg Download Assistant[26937]: Steinberg Download Assistant:Failed to launch JVM

I have the latest version of Java installed 8 (161)

Steinberg Download Assistant comes with its own Java runtime, so the version you’re maintaining on your system shouldn’t matter at all.

Did you install the latest version from the website?

https://www.steinberg.net/sda

Yes - of course - twice

I have the same issue. The Download Assistant starts for a few seconds, then quits. Running the file from terminal shows this error:

2018-11-09 07:43:17.251 Steinberg Download Assistant[1280:37472] Steinberg Download Assistant:Failed to launch JVM

I am on MacOS 10.14. Java is up to date. I have tried re-installing the SDA. SDA version 1.14.5.

Hi,

same problem for me, error"Error invoking method", “Failed to launch JVM”.
Windows 7 professional, tried with and without Java installed, with aria2 box unchecked.
It doesnt’ work. Has someone fixed the problem?

gcanavese, did you get any help with this? thanks.

I’m experiencing the same exact issue as described here. Just uninstalled the prior version, then installed v1.15.0 and the same error occurs. Tried running as administrator and various compatibility modes, but no changes. Running Windows 10 Pro 1809.

Sorry, can’t edit my prior post, because it’s not approved by mods yet, but wanted to post what I found.

For me, there was a bunch of ‘Aria2Process’ errors in the logs found in C:\Program Files (x86)\Steinberg\Download Assistant\app\logs. I uninstalled, then re-installed without the Aria component and it works. Granted, I’m missing that functionality now, but at least the app starts. I’d post the log but its around 30KB and not sure the mods want that in the forum.

Same issue

I have a similar issue on MacOS. The download assistant opens briefly then quits. No errors are displayed and there’s nothing useful in the console. I’ve tried uninstalling and reinstalling the assistant with and without aria. I bought Cubase 10 and can’t download it…

Possible Fix

I bought Cubase Pro 10 and have been wrestling with JVM issues for a couple of hours now. I’m on windows 10 (with the latest version of Java installed) and tried every potential fix I came across to no avail. But I found a way around this problem that, hopefully, will help be of use to someone. What I did was launching the program using the Executable Jar File found in “Program(x86)/Steinberg/Download Assistant/app” (or equivalent location on macOS) instead of the .exe. Doing this made the program start without any issue and is busy downloading Cubase Pro 10 as I type this.

Hopefully, this makes someone’s day a little less frustrating.

1 Like

Hey johnc,

Bought Cubase 10 Artist and have exact the same issue. Payed for software and cannot download and/or use it. Bit of a pain.
Tried several fixes, none seems to work.

Did you solve this issue and if yes, you mind letting me know how?
Thx

Cheers

Sascha

I try to download upgrade to Wavelab Elements and the same issue. Nowhere any solution so far.

What can Steinberg engineers say, can they help with providing at least a direct link download?

Hi,

I sent you PM.

Same problem here, downloaded Assistant but it fails to install on my iMac.
When will we get a solution to this problem from Steinberg please?

Same problem for me, have tried suggestions on forum including opening individual packages and using Terminal to open.
I’m using MacOS Sierra 10.12.6, Java says it is up to date.
This is the log I get in console when using Terminal to try and open it if anybody knows about this stuff and can get an answer from it.

Summary

Last login: Sat Aug 17 19:16:37 on ttys000
users-MacBook-Air:~ user$ /Applications/Steinberg\ Download\ Assistant/Steinberg\ Download\ Assistant.app/Contents/MacOS/Steinberg\ Download\ Assistant ; exit;
log4j:WARN No appenders could be found for logger (net.steinberg.elicenser.download.gui.common.FXMLLoaderFactory).
log4j:WARN Please initialize the log4j system properly.
Exception in Application init method
Exception in thread “main” java.lang.reflect.InvocationTargetException
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.springframework.boot.loader.MainMethodRunner.run(MainMethodRunner.java:48)
at org.springframework.boot.loader.Launcher.launch(Launcher.java:87)
at org.springframework.boot.loader.Launcher.launch(Launcher.java:50)
at org.springframework.boot.loader.JarLauncher.main(JarLauncher.java:51)
Caused by: java.lang.RuntimeException: Exception in Application init method
at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:912)
at com.sun.javafx.application.LauncherImpl.lambda$launchApplication$154(LauncherImpl.java:182)
at java.lang.Thread.run(Thread.java:748)
Caused by: java.lang.IllegalArgumentException: LoggerFactory is not a Logback LoggerContext but Logback is on the classpath. Either remove Logback or the competing implementation (class org.slf4j.impl.Log4jLoggerFactory loaded from file:/Library/Java/Extensions/slf4j-log4j12-1.5.8.jar). If you are using WebLogic you will need to add ‘org.slf4j’ to prefer-application-packages in WEB-INF/weblogic.xml: org.slf4j.impl.Log4jLoggerFactory
at org.springframework.util.Assert.instanceCheckFailed(Assert.java:389)
at org.springframework.util.Assert.isInstanceOf(Assert.java:327)
at org.springframework.boot.logging.logback.LogbackLoggingSystem.getLoggerContext(LogbackLoggingSystem.java:274)
at org.springframework.boot.logging.logback.LogbackLoggingSystem.beforeInitialize(LogbackLoggingSystem.java:98)
at org.springframework.boot.logging.LoggingApplicationListener.onApplicationStartingEvent(LoggingApplicationListener.java:231)
at org.springframework.boot.logging.LoggingApplicationListener.onApplicationEvent(LoggingApplicationListener.java:210)
at org.springframework.context.event.SimpleApplicationEventMulticaster.doInvokeListener(SimpleApplicationEventMulticaster.java:172)
at org.springframework.context.event.SimpleApplicationEventMulticaster.invokeListener(SimpleApplicationEventMulticaster.java:165)
at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:139)
at org.springframework.context.event.SimpleApplicationEventMulticaster.multicastEvent(SimpleApplicationEventMulticaster.java:122)
at org.springframework.boot.context.event.EventPublishingRunListener.starting(EventPublishingRunListener.java:69)
at org.springframework.boot.SpringApplicationRunListeners.starting(SpringApplicationRunListeners.java:48)
at org.springframework.boot.SpringApplication.run(SpringApplication.java:292)
at org.springframework.boot.SpringApplication.run(SpringApplication.java:1118)
at org.springframework.boot.SpringApplication.run(SpringApplication.java:1107)
at net.steinberg.elicenser.download.AbstractJavaFxApplicationSupport.init(AbstractJavaFxApplicationSupport.java:29)
at net.steinberg.elicenser.download.DownloaderManagerApp.init(DownloaderManagerApp.java:64)
at com.sun.javafx.application.LauncherImpl.launchApplication1(LauncherImpl.java:841)
… 2 more
2019-08-17 19:17:26.236 Steinberg Download Assistant[746:18830] Steinberg Download Assistant:Failed to launch JVM
logout
Saving session…
…copying shared history…
…saving history…truncating history files…
…completed.

[Process completed]

Thanks for his fix! Found your post after 3h of searching the web over and over! Made my day! Download is running. Thanks again!

had no problems like this till the update prior to this one came. there i applied the hack I found here to disable Aria2 during installation. Boom! Worked again. So I expected to solve it the same way this time. But no. This time even disabling Aria 2 during installation does not cure the problem. It seems there is a constant development to the worse till it will not work at all. Anyway. It was a good time and I liked it. I go back to the hard way and get it from the Steinberg page. Means I just de installed the Download Manager. Peace!