Steinberg Download Assistant fails with network problems

Is perhaps the server required for the Steinberg Download Assistant down? I cannot update Dorico, and I already tried that repeatedly in the recent days.

I cannot even download the Download Assistant itself, it seems. If I follow the link at the usual page below, then the network connection is immediately lost. Naturally, I confirmed that I otherwise my network is fine (otherwise I could likely not write this message on the same computer either).

Steinberg Download Assistant | Steinberg.

1 Like

Hi @torsten_anders just as info, I cannot confirm this, both the download and functionality of SDA seems to work ok. Did you try with a different browser?

Thanks for the helpful feedback. I tried downloading with Safari. I can install another browser.

However, also when just starting the currently installed SDA version, I get the following error message. The SDA does not even start, only shows this message.

Screenshot 2024-03-20 at 19.58.50

My network connection seems fine, though:

Could it be that there were any changes with SDA-related serves recently, and my version therefore does not find the server?

Thanks again.

Hello,

It might also be a problem with your service provider blocking some of Steinberg’s IP addresses for some reason. I experienced this once with a vendor website where I thought the vendor went out of business because I wasn’t able to get to their site for more than a year (but had no other problems), only to discover that everybody on a different ISP was able to get to that vendor site and everybody on my ISP was not. The problem ended up being that the vendor website was blocked by my ISP because someone at my ISP made a typo somewhere. The forum is on a different IP, so it probably wouldn’t be affected by any specific blocking for that.

Thanks for your response

a problem with your service provider blocking some of Steinberg’s IP addresses

Sure, in principle that could be a problem. However, it would be the first service that the provider blocked in over 5 years, and – the SDA did work before (e.g., I could update with it to version 5.1.10).

That is why I asked whether perhaps something changed there. If, however, things are working for others, then I will continue checking whether there is some workaround on my side. Just wanted to confirm also that the Steinberg server itself is not down.

Thanks again!

@torsten_anders Don’t know if this technically matters (in the complex internet chain), but did you try with a VPN?

Update: I meanwhile managed to upgrade Dorico. Thanks again for your help!

My workaround:
I could download the SDA via a remote computer on a completely different network. (Thanks NoMachine.) After reinstalling the SDA, I could start the software without the previously reported error. Instead, I was asked to log in for the Steinberg Download Assistant. After that, I could update Dorico.

So, perhaps the problem was some not very helpful error message, and the previous SDA version should instead have asked me to log in again? No idea.

Again, thanks for the feedback from so many people so quickly!

1 Like

Glad to hear you got it working.

I happen to work as a Network Engineer for an ISP as my main job. The thing that makes this entire thing a bit complex is that we are dealing with not just one Internet, but three Internets (yes, really). We have the old Internet running through the IPv4 protocol and the new Internet on the IPv6 protocol that not all companies and servers are on yet, and due to two major companies (Cogent and Hurricane Electric) not working nicely together, the IPv6 Internet is currently split into two different Internets, with most companies connected to both IPv6 Internets but some companies connected to one or the other.

The only reasons there aren’t more problems with this very fragmented insane setup is that web browsers have a feature called “happy eyeballs” that auto detect if the website is responding on the IPv4 Internet or IPv6 Internet. However, many ISPs are moving to various IPv6 transition mechanisms where the customer no longer gets an IPv4 address, and this prevents happy eyeballs from working. Then suddenly other issues could cause you to not be able to access certain sites, since if IPv6 is not working properly in that case due to a misconfiguration or blockage somewhere, the site just won’t load. These problems with IPv6 not being configured correctly often go undetected because people don’t notice it when “happy eyeballs” is working correctly.

Some of the Steinberg sites are on both IPv4 and IPv6 while others are on IPv4 only, so this distinction can be relevant.

4 Likes

Thank you @mducharme for this very interesting explanation of this “Behind The Bars”…oppss: “Behind The Scenes” of how the internet works. Fascinating! (and a bit frightening).

I had this recently as well on my laptop after I had been on a trip away from my home network. A simple restart seemed to fix it - worth a try.

If you’ve not run SDA recently, it’s possible that you are running a version older than the current 1.35.0, which can no longer connect to our servers due to expired certificates. Please try uninstalling SDA and reinstalling the latest version from here:

Windows: https://www.steinberg.net/sda-win
macOS: https://www.steinberg.net/sda-mac

1 Like

I have had all these bad connection problems recently. I could not download 1.35 either after trying three different browsers on my pc they all blocked the download page as unsafe as it was verified by aws.
I found a workaround to this by downloading the install file to by iPhone then emailing it to myself. After installing the 1.35 version it has the same check your internet connection error message. I don’t know if there is anything else I can do? But steinberg need to do something other than ignoring support tickets here

I have recently upgraded my halion to version 7 and it has disappeared completely from my products on activation manager now and gives no license found when I try to use it

If you want my theory on it, I think steinberg may have moved from physical to cloud server.

(post deleted by author)