Steinberg Download Assistant Nuendo 13

Fed up to spend hours restarting computer because Steinberg Download Assistant hang and/or crash…

When will you give us an alternative solution.


Had some errors and hanging while auto updating on a 2nd machine today. I just downloaded the installer from the site and it worked fine after that.

Maybe this helps…

1 Like

Download Assistant upgrade hung and said elicenser failed. I have purchased a Cubase Pro 13 upgrade from 11 and now I have an error that there is no license to upgrade ! Help!

Have you downloaded the Steinberg Activation Manager?

Thanks Wheels… am sorted now. It was related to the latest version (of Cubase sorry) doesn’t recognise the USB elicenser and wouldn’t update that… expected (but uncommunicated!) behaviour. Thanks for responding… jb

1 Like

I bought an upgrade from Spectralayers Pro 7 to Spectralayers Pro 10,
and… I can’t upgrade my license, when I try to upgrade it gives me an error

photo_2023-11-26 17.18.41

When I start Nuendo I get this error:

However, everything is fine in eLicenser CC

This is an upgrade from an eLicenser software to a Steinberg Licensing Software.
You need to select the Licence to upgrade somewhere in the process.

And it is not directly related to Steinberg Download Assistant.

I would reboot and try again. If that doesn’t fix the problems, reinstall eLicenser Control Center.

Thanks, I know. It seems to be a problem with the servers.
I had something similar when I upgraded my license from Nuendo 11 to 12.
The license upgrade process starts (after I select the license on the eLicenser key) and after a couple of minutes this error comes out.

Thank you!
I’ve been trying to upgrade my license for three days now)
Rebooted my computer many times and reinstalled elicenser CC. Still no luck

It looks to be an issue with the eLicenser Control Center on your machine - the error says that the inter-application communication between parts of the eLicenser installation on your computer is not working.

I would try uninstalling and reinstalling the eLicenser Control Center. If that doesn’t work, use a different computer to upgrade the licence. If that doesn’t work, it is possible that your USB eLicenser is damaged.

It might be worth opening a ticket with Steinberg support.

I installed Steinberg Download Assistant on my wife’s macbook and it worked the first time) I upgraded my license. I don’t know what it was or why, but now everything works!