Steinberg Download Assistant quits unexpectedly on launch

Please… I need help!
I’m on a MacBook Pro using macOS High Sierra (10.13.5) and I just downloaded the Steinberg Download Assistant (its latest version out there, 1.12.1) but, after the installation is finished, it does not start. I don’t get any error message or anything else… simply, it starts bouncing on the Dock and, after a second, it no longer does it.

I tried to open the Unix Executable inside the app contents (Contents > macOS folder) and a window opens showing what I suppose that’s the process of the app opening and an ending line like this:

Steinberg Download Assistant[976:18168] Steinberg Download Assistant:Failed to launch JVM

I will appreciate so much if someone could help me!


I found that the SDA is best launched by first downloading and running the Steinberg Download Assistant Setup utility; then by making sure that the actual SDA was where it was supposed to be (I had it in a ‘Dorico files’ folder and - understandably Setup hadn’t put the new version there - but at the root of /Applications. So I actually had two versions); and making sure I ran the correct latest version.

It shouldn’t be necessary but have you also restarted since the failure - perhaps having deleted what may be an incomplete SDA?


Thanks for your help! I completely uninstalled the SDA, restarted, downloaded again from the web (both Chrome and Safari) and reinstalled it and keeps crashing.
It is located under the Applications folder, so presumably, that’s the correct place for it.
I have Dorico 1.2.10 installed on the computer, BTW… :unamused:

I don’t know if I should try to do anything else…


The error and line you included suggest it’s a Java error.

You’re not in Russia, by any chance, are you?!

Two possible further steps to eliminate possible non-Java causes:

  1. do you need 1.2: if not, you could safely zip it up - and delete the original later - per this thread… and others like it?
  2. my SDAS (you did run that first, didn’t you?) is 112,993,713 bytes in length; and the SDA itself 227,886,449. Are yours the same (Cmnd I in the finder); if so, you have good downloads?

But I suspect something going on with the Java environment. Apparently SDA (don’t forget SDAS) has its own runtime. Could be some conflict there?


Nope, I’m not in Russia by any chance hahaha.
I already eliminated any Java installation I found on my computer, with no success on starting SDA.
Fortunately, and as a kind of workaround… I just installed the SDA on another computer and it has opened correctly. Hmm…

The issue has not been solved, but I temporarily got a solution for it.
Thank you very much, Mark! I really appreciate your dedication.
Albert. :slight_smile:

I don’t know whether SDA requires an external Java runtime to be installed on your computer, but it is a Java-based application. I’ll try to find out.

My pleasure, Albert: progress of sorts. Daniel is much better qualified, and much more likely, to help than I am now, of course. Good luck!

Albert, I asked the SDA team about your problem, and they think the problem is caused by some corruption in the fonts on your system. Can you try running Font Book and checking for any font validation errors, and resolve any that appear?

1 Like

Oh, thank you, Daniel!! I will take a look at it.

Thanks for pointing in the right direction. I had the same issue and it was solved by deactivating certain fonts.

It’s a shame though that this issues hasn’t been fixed even after two years. Anyways I got it working but it definitely left me with a bad taste.


Welcome to the forum, @bobtronic. I’m sorry that you ran into this issue. I believe it is endemic to the specific technology that SDA is built upon and so it’s difficult for us to fix.

You can of course download everything from the Steinberg website > Support > Downloads without bothering with the SDA.

Invariably, when I launch it, the first thing it wants to do is download an updated version of itself. :wink: Between Kontakt and EastWest, and Soundiron and Steinberg, the number of apps I have that do nothing except update things or download things is absurd.

Thanks for the info. Maybe this can be added to the knowledge base for future reference.

I tried that but it was such a hassle because you need all these different apps and in the end it still didn’t work out. I only wanted to try out Cubase Elements. Not a nice experience for a demo.

Unfortunately SDA doesn’t necessarily make it a whole lot nicer, given that you still have to click to download each installer, and then click again to install each one.