Steinberg Download Assistant unable to start

Hi there,
I know there are several same topics but it seems that Steinberg still hasn’t solved this important topic…
The DL assistant was working well until I’ve installed Halion 6 + Content. As the content update failed (I guess HD space) and re-booting the PC to re-install the content again, I just get error messages…
image
image
eLicenser and all the SW are working just this f*** DL assistant, which is necessary to install content …
Any advice? Any plans at Steinberg to solve this ever lasting problem issues with the DL assistant?
So much about 0 down time…

At this point, I would try to unistall, then reinstall it (the download page is here).

This, after having CAREFULLY read what’s in the Guide (Help Center article) link, available in the same page, as there is also the eLicencer involved…

I had the similar issue in an earlier stage of the SDL and it was related to a custom download location which no longer existed. Unfortunately, uninstalling and reinstalling kept the custom download path and if I remember correctly I could only solve it by recreating the download path (was a temp. drive) and then switch it back to default location. If you used an external drive for the download location you may attach any storage just to have the path availabel for a moment or - not sure if this works - you may use the SUBST command (Windows I assume?) to “fake” a local folder with a path.

@cubic13
Thanx, but I’m not new to Steinberg’s SW. So I know this part very well.

@Biochip
Thanx for this info. This seems to be the key because I’ve checked the library manager yesterday (due to the errors while installing the content package) and saw there several files which have not been copied (due to limited HD space). Unfortunately I’ve already cleaned-up the HD and I don’t remember the exact location anymore :hot_face:

I’m currently checking the DL Assistant log’s. And this doesn’t look good but maybe I’ll find the solution there…
2021-10-28 15:48:56.909 INFO 18844 — [JavaFX-Launcher] o.s.boot.SpringApplication : No active profile set, falling back to default profiles: default

Just created a support ticket as I 'm not close to any solution yet …
Update:
As expected, I haven’t received any FB from Steinberg yet.
But that’s our new world where the products (not only SW) are tested by the end-user and the support is cut due to company profit…
Re-creating the folders (could find them from the last working log file) didn’t solve this issue.
So it is related to Aria2Service…

2021-10-27 08:50:47.092 ERROR 6888 — [JavaFX-Launcher] n.s.e.d.d.aria2.internal.Aria2Service : An exception occurred while accessing aria2JService

Seems I’m getting closer to the issue…
Steinberg is looking in a temporary folder which has been deleted (cleaned-up):
…\AppData\Local\Temp\RarSFX0…
Unfortunately not.
I’m giving-up now and will uninstall all Steinberg SW and re-install it again…
Loosing again several useless hours of work… :hot_face: :hot_face: :hot_face:

SDA has stopped running. I attach screenshots. Reinstalling the program does nothing. What to do? I need your help.


Can’t even edit my own posts anymore…
Is the edit function limited to 4 times? Or related to answers? Just wondering…

All above issues are out of any use.
Nothing at all does solve the problem.
As I don’t have time yet to save all personal settings, de-install all SSW and re-install all SSW, just to (maybe) get the tiny SDA working again. This essential SW (for Steinberg SW download/install use only) shall work without any dependencies to installed Steinberg SW or problems during any Steinberg SW update. Any settings inside the SDA is useless when the SW doesn’t start-up nor is there a config file which can be edited (in case of trouble).

Sorry to read that you still didn’t find a solution. I just did a quick test with a clean Windows 10 machine (no SB software on it before) and installed the latest SDA. Then I changed the download default location to a folder on my C: drive. Then I closed SDA and deleted the folder SDA was set to save the downloads into. After starting SDA again it now tells me that the folder no longer exists and I need to select a new location. So they fixed that issue with missing path in any newer version. Before it had caused the JAVA error. Not sure what is going wrong on your system, as I see from the latest screenshots you are getting these errors also on Cubase start? Or am I mistaken?

Try this, if it still only concerns the SDA:

JUST A DISCLAIMER > DO IT ON YOUR OWN RISK

Open Windows Registry Editor (regedit.exe)
Browse to the location:

HKEY_CURRENT_USER\Software\JavaSoft\Prefs\net
Select the Steinberg entry and export it (as a backup)
Then delete the key then close the Registry editor and open SDA again. It should now set the download path to the default location.

@Biochip

Thanx for taking your time.
This confirms my result, too. Because I’ve re-installed Halion (there are still no personal settings inside) but the result was unchanged.
I’ve deleted nearly anything related to the SDA in the registry but without any success.
I’ve even installed Java8 without any success.
But as other people suggest, on my PC the*.jar file isn’t running at all. Just a short black window popping up…
Maybe some windows or security settings have accidently changed during the 30GByte content installtion where the disk space ran out.
This I’ll check next week on Monday when I’m back in the office…

Yes (mistake), that’s another problem from another person @ Evgeny_Parkhomenko
All my Steinberg SW’s are running well. Just the damned SDA not… :cold_face:

Thank you so much friends for responding to my topic. BUT I would like to get a response from representatives of Steinberg. How to solve this problem? I have Cubase, HALion, Groove Agent, WaveLab. All programs start and run. The problem arose only with SDA, and everything worked well before. I can’t even get a Novel Piano for HALion. Does this not seem to Steinberg nonsense?

Are you the same person as the OP? Anyways, good luck in getting a response by Steinberg. For some reason they get mute quite often as they really don’t care. It’s a shame but yeah…that’s how we have seen it

No, I am me. Thank you for support. I will be waiting for a response from Steinberg.

I’ve re-checked all security settings and there is no issue I could find.
So this problem will be never understood as I need to set-up a clean Windows System again…

Just to provide the final update for this issue:
I don’t know where this problem is related to, either Win10 or SDS / eLicenser.
Whatever has “destroyed” whatever settings after the failed HALION content installation (disk running out of space during installation [without removing the original files]), the only way to fix this problems is a clean Windows installation…
(I’m just setting up a new PC because of this trouble…) :hot_face:

Having suffered myself, but according to the instructions of the Steinberg technical support, I solved this problem myself. In my case, it worked. If anyone has exactly the same problem, try it.

Please follow these steps:
Go to the Windows start menu
2. Type “cmd” in the search field
3. Locate “Command Prompt” result – don’t run it yet
4. Click the right mouse button and select “Run as Administrator” option
5. Type: sfc /scannow
6. Wait until the scan is finished.
7. Now type: DISM.exe /Online /Cleanup-image /Restorehealth
8. Wait until the scan is finished (Usually 10-30 min.)
9. You can close the command prompt now
10.Uninstall Steinberg Download Assistant
11. Delete all folders in theese locations
C:\Users<USERNAME>\AppData\Local\Steinberg Download Assistant
C:\ProgramData\Steinberg\Download Assistant
C:\Program Files (x86)\Steinberg\Download Assistant
12.Install latest Steinberg Download Assistant
This should work.