Steinberg MR816X stopped working after updating BIOS


The situation is: my Steinberg MR816 X stopped working after I updated my BIOS. My MOBO is Asus P8H67-M PRO. I updated the Bios from version 0410 to the latest today. Windows 7 64-bit ultimate can find the driver, so can my recording software n- track studio BUT it says in media player that there is a problem with the sound device and does not work. Also says in n- track studio that the ASIO buffers have a problem “error creating Asio buffers”.

What should I do? I tried re-installing the Yamaha FW driver/MR tools but it did not help. I have no idea what to do. When I click the FW driver icon on the right lower side of Windows desktop it finds the card but when I try to use it it does not work.

Best regards.

Does anyone find this familiar? I still haven’t been able to get the card to work. I am beginning to think that somewhere the unit must have been damaged or the fireware card was damaged. The communication between the card and my windows 7 is not working.

I tried to install the card to another, older, computer but didn’t get it to work. Although, it is a older computer with win xp from 2004 I think and maybe the MOBO is not compatible. I used the same fireware card in both pcs.

Is there a way for me to test if the card itself is ok or if it is my pc hardware mobo or the fireware card?

Steinberg has not replied to my email. How long does it usually take for them to reply?

This is very stressful as I need my card.

So, I reinstalled Windows 7 and the problem still exists “…sound device not working properly…” It is either the motherboard, the fireware card or the Steinberg MR which is broken/malfunctioning.

Might be that the fireware card became outdated/incompatible after the Bios update? It is a pretty old card. But the MR control panel does find the card so would that suggest it is not the fireware card?
COuld it be the mobo that is the problem even though windows and the MR control panel does find the card?


After hours of googling help I’ve been playing with the fireware drivers and finally I’ve been able to get sound out of the card…


There is something wrong with the sound; a very loud hissing which was not there before. And also before when I adjusted the volume of the card the hissing from teh speakers did not get any louder when increasing the volume but now it does! Also, the sound is somehow different. Thinner.

Is there now something wrong with the MR itself? Is this a typical symptom of a damaged card?