Steinberg UR44 and Cubase do not cooperate well

I recently changed my rusty (but still good) M-Audio ProFire 2626 to Steinberg UR44, mainly to be able to upgrade later to Windows 8 or 10. With M-Audio it has never been an issue to listen to an output from external MIDI instruments. As long as I had their outputs included in an input bus I could simply start the song playback and hear what they played.

Not anymore after upgrading to UR44. After trying, failing and swearing I found a workflow that let me hear my external MIDI instruments, but it looks quite ackward. Here’s what I had to do:

  1. Create an audio track for each external MIDI instrument.
  2. Set the instrument output as input for each such track.
  3. Enable monitoring of each such track.

Then if play the song I am able to hear the sound of these instuments. If I mute these audio tracks or disable their monitoring, I don’t hear anything.

Last but not least - sometimes (but only sometimes!) I manage without these extra audio tracks if I just start the UR44 dsp mixer application. Then the sound magically reappears.

Never had this problem with other sound cards.

Try to disable direct monitoring in cubase, and use the soundcards mixer for monitoring instead.

Thanks, I’ll try. So you mean this is by design, or what you suggest is a workaround, it is not supposed to be this way?

If direct monitoring is enabled in Cubase then the way you are doing it is the correct way. There is no right or wrong way of doing it, it is a choice. It can be a better option to do the monitoring in the driver/mixer, if you want to hear your instruments without having to start Cubase first. If direct monitoring is enabled in Cubase it takes over the controls, so to speak, that way you don’t have to open the ur44 mixer, that’s the benefit. It’s just a switch that determines if your monitoring is controlled by Cubase or the driver software, latency is the same.

Thank you.