Stem Thickness issues with Half Notes

Hi everybody,
for several reasons, I need slightly thicker stems and stave lines than the Dorico default. Unfortunately, that causes some unpleasant visual problems with half notes at the points where the stem is attached to the head:

I presume there is no way to prevent that currently but maybe someone has an idea. In any case I wanted to bring up this issue for further development considerations.


The default stem width goes with the design of the default noteheads. There is some leeway, but to accommodate stems that thick you will need a different notehead.

Or perhaps you could use post-processing to thicken up everything on the page? Then you could use the default lines again.

You’ll need to adjust the stem anchor positions in the Note head Set editor to a point where the stem is completely masked by the notehead (and then reduce the stem lengths accordingly in Engraving Options).

Thanks @Mark_Johnson and @benwiggy

Unfortunately not everything should be thickened so this doesn’t really work.

There unfortunately is no usable point of contact where the stem is completely masked, properly attached and doesn’t protrude into the notehead.

The most ideal solution would be if the white space in the notehead would only be transparent for staff lines.

Anyway, after printing it, the problem is barely visible on the page so probably not too big of a deal.

Thanks for your help nevertheless,