STILL can't get remote devices working...

As reported back in the WL 8 forum, I’m still not able to get plug-ins to see MIDI controllers. I believe I understand how it needs to be setup, followed the prompts, and have tried a dozen times by now. My device is setup as a device in the Remote Devices window. I’ve edited the shortcuts and assigned them to parameters-- tried both the Custom Parameters and the dedicated Studio EQ ones. I enter the edit mode in the plug-in window, move the cursor over the control, move the hardware control…and nothing ever happens.

I know MIDI is getting to WL, because the MIDI learn feature works when setting up the parameters. Tried multiple plug-ins, multiple controllers.

Also, I belive WL is still reading the CC# offset by +1 from what the controller is putting out.

What info can I provide to improve this?

Thanks,
Brian

Please post a screenshot of your “Custom Parameters” settings.
When you make an assignment on the plugin, do you see the popup window “Done” displayed for 2 seconds?

Hi,
It’s attached. Nope, no indication anything is happening when I put the mouse over a parameter and move a defined control…

Thanks,
Brian
Screen Shot 2016-04-12 at 5.42.07 PM.png

Nope, no indication anything is happening when I put the mouse over a parameter and move a defined control…

Are you aware about the registration mode. That is, press Control + Click on this button:
2016-04-13_07-59-13.png

Hi,
Yes, I’ve entered that mode (I assume cmd+click on a Mac). I’m not sure if the problem is MIDI getting to the plug-in itself (it gets to WL), or that the CC# WL receives when learning seem to be -1 from what the controller is sending. I’ve linked to a screen recording of my attempt, including a 3rd-party MIDI monitor to confirm the MIDI data:

https://dl.dropboxusercontent.com/u/5383787/Remote%20Devices.mov

Thanks a lot,
Brian

Any updates on this? Was my screen recording helpful?

Will be checked soon.

Any progress with this? Baffling to me…

Yes. Next update should happen in a few weeks.

PG,
This is STILL broken for me in 9.0.20, which I spent a month waiting for. No difference in the problems now vs. 9.0.15, repeatable across entirely different Mac systems. See the screen recording already created earlier showing the failure of MIDI communication to plug-in windows. Also, a new one showing that WL is reading MIDI CC# +1 from their output:

https://dl.dropboxusercontent.com/u/5383787/MIDI.mov

I have received very little feedback on what the known-issues actually are with these broken features. Let me know if I should contact Steinberg support, or there’s another way it should be handled.

Many thanks,
Brian

The +1 offset is only a display thing. Instead of displaying from 0, WaveLab displays from 1.
This can’t explain other problems you might have. Which is?..

So, when WL gets CC# 9, it understands it as 9, but displays 10? Or actually understands it as 10? IMO, this should be an option, if not changed- it is a layer of confusion, and MIDI CC#'s are rarely counted from 1.

I have detailed the inability get any plug-ins from recognizing MIDI input above, with screen recordings…
https://www.steinberg.net/forums/viewtopic.php?f=244&t=95787&p=542523#p531105