Still issues with output!

As I have posted previously, although I came hear any track added to a new project, I get no audio output when I import a MIDI file that works perfectly ok in garage band etc. I have installed all the latest fixes for El Capitan.
After several frustrating days, I think I can see what the issues that have no idea how to resolve it. Everytime I Google the problem I get results that are way more complex than anything I want to do which is just play a file. I’ve had no response from Steinberg so this is my last resort before I go back to garage band for good!
If I check the Inspector for a inbuilt drum track I added to an imported MIDI file it shows a stereo output, and the output is good.
If I check the inspector for any of the tracks in the file, which have no audio output, it shows not connected and I can find no way of changing this, no matter what I type into the box, it just says not connected. Please see attached pics I would be grateful of any help, because my patience is just about finished!
LE copy.jpg

Hi,

These are MIDI tracks, right? It seems, you have no Instrument Track, an Instrument Rack or any MIDI Device. Please Add an Instrument Track.

Hi, Thanks for trying to help me.

As you may have realised, I’m totally new to Cubase (although I have lots of experience with software and instrumentation), and I’m not sure what you mean.
I have imported several midi files that all work fine in other applications, but not in Cubase LE8. I have attached a screenshot of an imported file, which gives no audible output and even though you can see the visual output working.
I then added 01 90bpm dry drum track and get good audio output.
I can’t find any way of changing the output from ''not connected" in Inspector.
Does Cubase not accept MIDI files that have not actually been created on this machine?
Thanks
Dave
LE8.jpg

Hi,

What is you File Import settings, please? Open Preferences > MIDI > MIDI File. Here, you can find File Import. The most important part is the Destination. Could you send a screenshot of this settings, please? Do you have MIDI tracks, HALion Sonic multi-timbral or Instrument tracks HALion Sonic SE. I would recommend you Instrument tracks.

Hi Martin, thanks for such a quick reply!
Heres the screen shot. MIDI Tracks was selected, this is the only option when I click on the destination arrow.
Thanks
Dave
zzz.jpg

Hi,

You are on Cubase LE, right? All other Cubase derivates have more options here, as I described. Unfortunately, the LE version is very limited here, so you cannot import MIDI file, and use an Instrument track as a destination.

So, the only one way in Cubase LE is to import the MIDI File. Add an Instrument track(s) with the instrument (and sound), and move all MIDI data (events) from imported MIDI tracks to these Instrument tracks.

Or upgrade to Cubase Elements (at least), which does it automatically for you.

OK Thanks, appreciate your help but a bit disappointed.
I was hoping this would be a replacement for Garage Band, but I guests just an enticement to get you to pay for an upgrade. All my mates have unofficial downloads of Cubase Pro, but I didn’t want to go that route!
Thanks again, just wish it was made clear in the Steinberg documentation!
Incidentally, I have just checked my version and it is Cubase LE AI Elements 8 (another thing I found confusing, all the versions with similar names etc.!) So tis is no good?
Dave

Hi,

You can check the exact version during the start screen or from the application, if you select About from the Help menu. The application itself is in fact the same (LE/AI/Elements). Just the Activation code decides, which function is available.