Stock plugins don't show graphics only sliders

Cubase pro 11.0.20, NVDIA Quadro 5000, HP Z820, Windows 10

Not quite sure when this started happening but I have no graphics in any of my stock Steinberg plugins in Cubase since my last upgrade. I did a few searches but didn’t come up with any fixes. Maybe the wording. Not sure. If anyone could help with this I would be very grateful. Everything is running fine but this is a pain. I have a second license and installation on a laptop that doesn’t have this issue.


Click to the Functions (triangle in the upper right corner of the plug-in window) and choose the Switch to Plug-In Editor option.

It doesn’t seem to be an option , any idea why?


Could you try in the Cubase Safe Start Mode [Disable preferences], please?

I tried that , deleted my current preferences and not much change, no difference… restarted again with 3rd party disabled just to make sure although I’m sure that wouldn’t affect stock plugins. no change.
It’s not a show stopper for current project, just annoying


As you are using NVIDIA, please try this:

  • Download the latest Studio driver version from here.
  • Disconnect the computer from Internet to make sure Windows will not download and install own graphic driver.
  • Uninstall the NVIDIA driver.
  • Restart computer.
  • Start the NVIDIA driver installation (as administrator).
  • Don’t install the whole package, use the Custom (Advanced) settings.
  • Disable everything (don’t install NVIDIA Experience, PhysX, etc.), keep just the video driver enabled.
  • Connect your computer to the internet.

Unfortunately that solution didn’t work here. Possibly due to any newer version of the Quadro K5000 NVDIA driver telling me it’s not compatible with the hardware even though I’m staring at the Quadro K5000 on the side of the card. It most certainly looks like a graphics issue. It was working so I can only assume that updates screwed it. If there’s a thread with recommended compatible graphics cards I’d be very appreciative if someone could link me to it. I’d be quite happy to get rid of it and stick something a little more compatible in. Thanks for helping out