Strange bug in Cubase 12 when editing channel settings


I have this strange bug in Cubase 12, when i press the “Edit Channel Settings” on some Tracks the CPU Spikes up hard.

For example:
I press “Edit Channel Settings” on Sampler track the CPU is normal. Then, i press “Edit Channel Settings” on the Master BUS and the CPU spikes up.

I have attached a video for it:

  • First time i hit “Edit Channel Settings” on HI-HATS channel, everything works fine at this point.

  • Then, when i hit “Edit Channel Settings” on the Master BUS everything spikes up as you can see in the video.

This never happened to me before. All my plugins are up to date, even the DAW is up to date and i just installed a fresh Windows on a new computer.

Does anyone know why this is happening?

These are my laptop specs:

  • i7-10th gen
  • 32GB RAM
  • SSD Samsung EVO Plus 970
  • OS : Windows 10

Thank you so much, have a good day!

Do you hear any artifacts?
If not, what exactly is the problem?
Did you try to change buffer size?
ASIO guard is on?

Yes, there are artifacts! As you can see in the video the audio keeps intrerupting, the performance meter goes red.
I have changed the buffer size and i have turned the ASIO guard on.
As i said, its strange…

Sorry, audio means hearing, not seeing.

This does not mean anything as single information.

Maybe your system reached its limit?
Intel Laptop processors are not that fast as anybody thinks.
The kind of plugins could be of interest as well…

But it only happens when the Channel Settings window is open for a specific channel.
If that was performance related (CPU too slow, plugins too demanding), wouldn’t the performance meter stay high even with the Channel Settings window closed ?

What’s more surprising is that it doesn’t seem to be a classic performance issue. We literally see that the performance meters are stuck at zero, and the tracks’ level meters and cursor reset/stutter, which means the audio engine resets repeatedly. If it was a classic performance issue, the meters would max out and stay at 100% and the audio would kind of make a “buzzing” noise.

To me this seems to be more of a Cubase-related issue than a System-related issue.

1 Like

Yes, this is what i was talking about.
It seems to be a problem, and i dont know how to fix it. As i said, i tried even on a fresh OS install (W11).

Have you looked at windows task manager performance how the real CPU usage of your system is?
To me it looks like the system is so under load that the GUI isn’t able to update properly (the GUI threads are a different priority than the audio threads).
Why this happen when you open the edit window for the master bus is admittedly somewhat weird. Does it happen just in this project or in others, too? Does it also happen if you disable (not just bypass) all the plugins on the master channel?

The CPU is good in task manager, there is no problem with the CPU. My computer runs good. As i said on Cubase 11 i didn’t have this problem.
It is strange because if it was from the CPU even with the “Edit Channel Settings” unopened, it should have SPIKED.
And yes, this happens in other projects too. And its not just the master bus, i can click on any other track that has VST’s on it and still happens.

So with C11 on the same computer there are no problems?
What if you do not open any channel settings windows and just let the project play through?
Also, in task manager CPU performance view, could you make sure that it shows dedicated graphs for each core (right click on the graph to configure that)? Default is just an average graph for all cores, which doesn’t help if it just one core that’s saturated.
I still have a hard time believing that it’s caused by the opening of the settings window. Sure, weird stuff happens, but we want to be sure it’s not a red herring…

On the first picture i was on a track that has 0 VST plugins.
Picture 1

On the second picture i was on the master bus.
Picture 2

Even when i switch between them and i play no audio, the performance metter gets high. Just by opening the project and swich between the “Edit Channel Settings” (just by doing nothing at all, just switching).

What comes to my mind here is Asio guard beeing able to work.
The first picture shows a selected VST Instrument, record enabled ( by selection? preferences?)
This will set a the Signal path to realtime, f.E. no asio guard for the Instrumen and its signal path, resulting in much higher demands on the system.
On the second picture it looks like nothing is record enabled, so asio guard presumably helps to relax the system.

Makes sense here?


The second picture is the one that spikes up… what relaxing, its exploding :rofl:

The first core is the other way round though.
Sorry, should have read more carefully… :see_no_evil:

haha no problem :smiling_face:

Does this also happen on light to moderately loaded projects, or just with heavy projects ?

I don’t know what to say, that’s the first time I see this issue actually.
You should investigate if you are able to replicate it under different conditions, for example without inserts, different routing, different instruments, etc. Perhaps something is causing it, but that’s weird because the only thing happening in the Channel Settings is the spectrum graph. I really fail to understand how such an issue could happen. :thinking:

And based on your screenshots it’s definitely not a system/performance issue.
This comes from Cubase, I’m sure of it. That’s an internal bug.

1 Like

That’s why I was thinking that the channel settings might be a red herring and the problem lies elsewhere.
The funny thing is that when the VSTi Mellotron track is activated/record armed, the first core is pretty much saturated, I’d expect dropouts there.
In the second screenshot, the master out is selected and as far as I can see, no track is record enabled, which means possibly everything is running on ASIOGuard (and CPU saturation drops). Maybe that’s the more important difference than the channel settings, for whatever reason?
The one thing that makes me doubt that it is solely a Cubase issue is that it seems to be the first time someone has it, several months after Cubase has been released (and as you know, several performance issues have been detected immediately after the first release…). Or it is a weird combination of computer, devices and plugins that no one else has :wink:

@largekat23 could you please test this by opening the master channel settings without selecting the master? Just leave the Mellotron track selected.
And then please test this: stay on the Mellotron track but disable “record”.
Also, just out of curiosity, which ASIOguard level are you on.
Also, since you wrote you did a fresh install of Windows on your new laptop, do you still have another computer? Does C12 show the same behavior there?

I do not have another computer :pensive:
I have tried what you said and i still have the same problem.
I also opened even another project that has different VST’s on it… still the same problem.

Could you a bit more precise? What did happen when you did this:

This provoked the dropouts? You did not select the master track?

and this:

This also provoked the dropouts?

I did test this here with a fairly heavy project (not as CPU intensive as yours though), and I cannot reproduce this behaviour at all.

I have honestly no ideas atm what the problem could be, but what I personally would do to try to isolate the problem:
First, do every test with a freshly started Cubase.
Just change one thing at a time (e.g.: only click on different “e” without selecting other tracks). Or just switch between track. Or just enable/disable record.
If you are sure that it is just because of opening the edit window, and only on tracks those with effect plugins loaded, successively unload one plugin after the other and see whether that changes anything.
If that doesn’t yield results, I’d try disabling the spectrum graph in the edit channel window.
And, as @Louis_R wrote, test it under different conditions to see whether it is in any way load related, or plugin related.
It is tedious, but precise testing is everything in bug hunting…

Just another stab in the dark: have you tried updating your graphics card driver?

I have installed freshly Cubase on a new Windows 11 OS. I have the same problem.
I have also updated the BIOS and i have checked to install the latest drivers for my laptop.
The problem still occurs, and i have tested it on different projects with different plugins.

Seems so strange. I don’t know what to do, i have tried everything.