strange chord symbol behaviour

Hi there,

I regularly encounter some strange behaviour when entering chord symbols in Dorico. Sometimes Dorico will only display part of a chord symbol or nothing at all even though it remembers the chord in the popover. Since I couldn’t figure out yet, when the bug appears, I tried to catch it with Gifox for you to see…
2018-05-08 13.55.00.gif
Any ideas what’s going on, there?

Are the lyrics “ain’t no reason - make it better”? :wink:
I don’t know why it does this but I’ve noticed the same behaviour in Galley View. When I flick back to a page Virw the chord symbols seem to reappear.

It looks to me as if Dorico (presumably incorrectly) thinks that the preceding chord has the same root as the one just entered, so it hides the root of the new one. I’d need to see the project if possible. I daresay it’s a bug but we’ll need a reproducible case in order to fix it.

Daniel, just to clarify, this happens a) in projects where the option is set to always show both elements of the chord, even if the main chord is repeated over a different root, and b) regardless of whether the new chord has anything at all to do with the previous chord.

I’ve tried and struggled to come up with a reproduceable case in the past, or I’d have posted about it myself.

Your observations may be correct, Leo, but I think it’s too much of a coincidence that the root part of the chord symbol doesn’t draw, so I strongly suspect that there is some problem with how Dorico determines whether the root of the chord being input is the same as the previous one.

This bug also appeared with random chords on other projects. Sometimes, Dorico strips chord extensions and writes just D instead of D7#9, sometimes nothing at all. Most of the times, it helps to alter the chord symbol with the popover and then change it back to what it originally should be. Sometimes, I have to delete the chord symbol and reenter it to display correctly… really quite unpredictable.

I also experienced many strange behviours regarding chord symbols similar to the one described here. Also, more than often chords don’t draw on all parts. Mostly in Galley view.

It seems to me that in v2.1.10, the chord symbol bug is back. I thought, it was already fixed in v2.0. But I still find random chord symbols that don’t show up at all or have elements missing: I just had a Bm(b5) showing as Bm( ). Sometimes they even disappear later after they already did show up correctly on entry…

The bug won’t be fixed because as yet we don’t know under what circumstances it occurs, so we’re unable to fix it so far. If you have any reproducible steps that cause the main part of the chord symbol to go missing, please let us know what they are.