Strange Problem with HALion & Staccato

This is a bit baffling. I’m using basic HALion Sonic SE here - one instrument (violin) which is playing all staccato quarter note double stops. For some reason, one of the double stops is not playing staccato. Here’s a picture to illustrate:


Notice bar 3 in the Key Editor at the bottom. For the middle notes (F#-D) - the playback technique is set to Natural. All the other notes are properly set to Staccato, but for some reason Dorico is not picking up the staccato for just that one double stop. I thought for a while that this might be some strange interaction because the quarter notes start on the upbeat. However, if I change this to an 8th note, then the NEXT notes become natural (not staccato).

I’m pretty sure I have everything configured properly. Here’s the Endpoint setup:


I’ve also attached the Dorico file.

Any thoughts/suggestions? BTW - This is NOT happening with NotePerformer.
Staccato Violin Problem.dorico (919.5 KB)

EDIT: It’s not related to the double stops. I changed to single notes and it still happens.

This has been discussed before, including in the thread I’ll link to below (though you’re certainly forgiven for missing it, as it’s buried in the middle):

The bottom line is that Dorico interprets the staccato differently when written as a tie chain rather than written as a single note. I think this is something we should change, but I’m not sure exactly how or when we might do that.

1 Like

Thanks Daniel - and you’re right - I never would have found it. :slightly_smiling_face:

So as long as the notes are not crossing a bar line we can use force duration and things will sound as intended (within the limitations of the Halion library) but if we cross a bar line then we have to do some tricks. E.g. - I turned off playback for the note that was crossing the bar line then added a second voice playing just the 8th staccato - it sounds slightly different but it’s close enough . . .

For what it’s worth, after we talked about this last week, I spent some time tweaking the way Dorico behaves in this regard, and in the next update, it will be possible to specify the maximum played duration at which the staccato playback technique should be used, rather than shortening the note via MIDI, and this will apply regardless of whether the note is written with ties, or appears as a single notehead. So your project would always play the staccato sound for all of the notes by default.

3 Likes

Thanks Daniel, very cool! Is there any way to make it a default behavior that articulations of duration go on the first note in a tie chain?

You can always change the tie-chain position property, but mostly I find Dorico behaves as I would expect to see in a score.

There are options in the Ties section of the Articulations page of Engraving Options that allow you to specify the default placement of articulations relative to tied notes.

Thanks again Daniel!