Strange sample rate issue

I’ve been struggling with an issue and could use some help. A couple of others have had the same issue but have ‘fixed it for future projects’ and I need to fix it in a working project.
My project was set to 44.1
(I thought) my interface (Audient ID22) was set to 44.1
Windows device setting for the ID22 was actually set to 48kHz
So the problem is this:
All the audio files were actually recorded at 48kHz but show as 44.1 in the project pool.
If I correct all the settings and put everything in 44.1, all the MIDI instruments are slow and so are all the audio tracks (and pitched down).

So I wonder if the best way is to finish the project with the incorrect settings then upsample it later but surely that will have the same issue with thinking the audio files are 44.1 when they are not?

I wish there was a warning other than the little yellow triangle when you finally go to the project setting to work out what is going wrong…

Any suggestions will be most welcome. My mind is in a loop of ‘it doesn’t matter what the sample rate is, it will always be wrong and export incorrectly no matter what I change it to’…

Hi,

Is the Project set to 44.1 or 48kHz, please? Is the Audio Device set to 44.1 or 48kHz, please?

This has no influence on Cubase. Cubase can set the sample rate for the device as needed. If there is something not possible, you get an error message. If you say don’t warn again, you get no other warnings.
If Cubase can’t set the sample rate something is wrong in your configuration.

Why do you think this? The pool shows 44.1 kHz, trust it.

I suggest what I always suggest, disable external sync.
Make sure that Cubase controls the settings.

@st10ss: If I have disabled some warning then I don’t remember. Never had this issue before and switch between sample rates frequently. With the device settings to 48kHz, If the project is set to 44.1 and I set the interface at it’s control panel to 44.1, then click back on to Cubase, something (windows? Cubase?) then switches the ID22 back to 48kHz. If I then record, the interface is still at 48kHz but the file created in the Pool is labeled as 44.1

Everything seems fine until I try and mix down. Then the mixed down output is slow/pitched down

I do not trust it as it is very definitly lying to me :slight_smile:

I appreciate that it is a bit confusing.

The project is set to 44.1kHz
The interface is set to 48kHz
Audio is recorded
Audio shows in pool as 44.1kHz
Track gets finished with many audio and midi parts
Audio mixdown
Mix down is slow and pitched down

I need some way of fixing this in the project. Presumably with incorrect settings as ‘fixing’ the problem just creates the problem in the project (as in, it slows the whole project down now making everything slow)

Hi,

This is the problem. Your project should be always in sync with the Audio Device.

I am fully aware of this. That doesn’t help me fix it though.

I will never make this mistake again. But I’m now completely stuck as there was no warning that I had a mismatch. I think the problem was that I opened an old project for the same artist which was recorded at 44.1kHz but my interface settings were at 48kHz as that is normal for me. Either way, if you can help me think of a solution that would be great…

There are a few others that have had this issue but with no resolution:

The last of these suggests a workaround but I actually don’t understand what they are doing. Maybe continuing with the project (with the incorrect settings) doing the final mix, opening that and resampling it to 48kHz then exporting it as 44.1kHz? This seems like a terrible solution though and I’d much prefer a more robust way of fixing it.

Presumably the files are actually 48khz , but the header (info contained in the file) says it is 44khz. You just need to change the info in the header to be corrected to show that it is in fact 48khz.
Have a check here Header Investigator

This happens if I try to change sample rate in a project. Cubase tries to convert all files to the new sample rate.

Normally it is very easy, create a project and Cubase is setting the sample rate for the hardware. There is no need to change anything. This is not working, if you let the hardware set the sample rate.
But why should anybody need this?
I have no idea. (ok, in fact I know why it is needed, but it’s not relevant for 90% of the systems)

What other digital devices are involved in your system?

I think it might be because the ID22 is using an external clock source. So I have an optical 8 channel preamp which it is using. Obviously it is all fine when I start a new project, everything is fine. But when opening an old project with a different sample rate, it doesn’t give any warnings that there is a mismatch.

One thing I have just tried is opening the project as normal, then converting the project settings to 48kHz without converting the audio files. This works for the audio but now all the midi is all over the place and the audio tracks don’t fit to the grid (obviously).

So my guess is that I need to find the correct tempo of the 44.1 audio then match the project tempo to that and re-do all the midi.

I can’t print the midi in the old version then work with that because the client hasn’t signed it off and there may be a lot more work to do.

I just tried this as on the face of it, it sounds like a great solution. For some reason it seems to destroy the audio though. What I did was export mixdown and then changed the header data to 48kHz. It almost sounds right but it’s not quite there. I don’t know why this might be?

But why?
Sync the preamp to the ID22. That prevents from a lot of hassle.
You can set the clock source to internal, and the setup follows the sample rate changes.

Just a second ADAT cable, if the preamp supports it.
Which one is it?
Just a few expensive preamps provide better clock than most interfaces.

At this stage I am not worried about the future… The future is all fine. I am mostly concerned about the mess it has created.

So far, to fix it, I have changed all my settings to 48kHz, reopened the 44.1kHz project then changed the project settings to 48kHz without converting the audio. I think that this will be fine for the audio but it has had very odd effects on the midi data for some reason and now it is all misaligned to the grid…

You must change the headers in the original files. I’ve done it in the past with no issues

1 Like

The problem here is that the audio is time based, but the midi is tempo based.
You could rename your topic to attract other users to your specific problem.

Maybe this could help you.

Thank you.

So. For the sake of conclusion… You have two options:

  1. You can leave your project in 44.1kHz and re-header all the audio files in the pool using header investigator
  2. You can change all your settings (devive settings for your interface, on the devce itself, and then the project settings in Cubase) and when it asks you to convert the files, leave them at 44.1 (say no when it asks you) and keep them in the sample positions (say yes to the next dialog). But you’ll probably have to re-do the midi if you have any.

This is an annoying issue though with Cubase and not sure if it can be fixed in the software because we/I don’t really know if the problem is with the setup, the drivers or the software.

…and also… …Check the advanced device settings in windows, your interface settings, any external clocking device settings and your Cubase project settings before doing any recording.

Please make this as a solution if you feel it is helpful

WE know that the issue is the setup.

Yes. But it would be nice if there was a warning when opening a project where the sample rate is different to your device settings. It would save a lot of pain