Strange VST drop out problem

I’m using Cubase 5 Studio along with various VSTs and midi controllers along with a MOTU ultralite for live performance. New Win 7 quad core laptop. Cubase and all VSTs fully updated.

Here’s the problem. Half of my keyboard setup uses an old Oberheim Matrix midi out to Axiom 61 Midi in, then both by USB to the laptop for prologue synth and Native Instruments B4II. Most of the time, everything operates properly. Every now and then, seemingly after using mediabay for an extended time to play songs (i.e. not playing the keyboards), I’ll try to use the keyboards again and they no longer trigger sounds. The only way to recover is to completely power down the MOTU including the power supply. If instead I only close and reopen Cubase, or reboot, or power down the MOTU using the box’s power switch, or power off the Oberheim and or Axiom, the 2 problematic kbs and vsts don’t recover.

Interesting to note that the other half of my setup (Korg M1 midi to Novation midi in to usb to VSTs) never has this problem, even when the other side drops out.

What could be the root cause and solution to this?

Thanks
Tom

Does it help to use the Emulated MIDI ports for the device?

Not sure about that. I’m not in front of my system now but can check things out tonight after work.

I’m using Axiom USB In1 for the Axiom generated data meant for the B4II track and Axiom USB In2 for the Oberheim generated data meant for the Prologue track.

But maybe you mean I have to check under device/setup/midi (as I recall) and select emulated midi?

Thanks

Yeah, depending on version you have to move the MIDI Port Enabler or enableemulated file up one directory for them to show. Use System Timestamp may also be an option. Sounds like the device is loosing sync over time, possibly due to clock/ jitter issues.

OK, so fired it up and looked at MIDI Port Setup. None of the ports showed as emulated. So I closed Cubase, then I copied the enableemulated file up one directory and launched Cubase. MIDI Port Setup showed all the MIDI ports as emulated EXCEPT for Axiom MIDI In and Axiom Ext MIDI In, the two that I care about. So that’s a bit odd. Any thoughts on that? Anyway pending further advice I undid this fix to see whether the next one works on its own.

Next, I was able to toggle on the System Timestamp, and did a test tonight without and VST drops, but that isn’t conclusive since the problem doesn’t happen every time I use the system. I’ll have to wait a couple of weekends if not months to know for sure that there are no malfunctions.

Thanks,
Tom

OK, so the system timestamp definitely did not help. Had a rehearsal this weekend and lost the two VSTs half way through. And yet during my previous test during the week, I didn’t see a problem. That makes me think the failure somehow relates to how much information cubase has seen. I was playing guitar mostly this weekend, so that was analog data. Also did a bunch of searches using media bay.

I’m still puzzled that the Axiom didn’t show up as emulated midi when I moved the emulatedmidi file. Maybe I should do a rehearsal with emulatedmidi even though the axiom didn’t show up as such.

After that, I’ll have to try 1) avoiding using mediabay during rehearsal, or 2) disconnect the Oberheim and go through a rehearsal without that as a midi controller. Then 3) doing a rehearsal without the Axiom and hence the Oberheim as well.

See if moving the Port Filter file up a directory also makes them show.

Yes, moving the portfilter file up made them show. I selected emulated midi for all my controllers, and had a rehearsal. I didn’t lose any VSTs during the rehearsal. However, early on, the Axiom got stuck on some notes so I had to close Cubase and relaunch. I guess sending a panic command on the Axiom would have worked, but since it never happened before, I didn’t know the button sequence to send that.

I’m thinking next that I should use emulated midi only for selected controllers, maybe 1) just the Oberheim (Axiom USB2) or 2) the Oberheim and the Axiom, because I read that emulation causes higher latency.

I’ll try 1) first.

I tried both 1) and 2) as above, and still lost the Oberheim -> Axiom keyboard chain.

For the case 2) where I was using emulated midi for both the Oberheim and Axiom, after the dropout I tested whether the other keyboard chain (M1 -> Novation -> USB in) could trigger the dropped VSTs by changing the send channel on the M1. Both VSTs could be triggered.

Also for case 2), I only played the Novation at first, then left the system unattended for a few hours. No other apps such as mediabay were used.

Any other ideas?

Thanks,
Tom

Make sure a power saving option isn’t enabled for the USB ports.

I think that solved my problem. Power saving was enabled on USB even though I had chosen the “high performance” default profile. Since disabling, I haven’t had a problem, even though I’ve gone back to using non-emulated midi. I still have “system timestamp” on, thinking that it can’t do any harm.

Thank you very much for helping with this! It was a frustrating problem and I’m glad to know it had nothing to do with Cubase or my hardware.

I wonder, if you are aware of a document that summarizes how to optimize Win 7 for music apps, please let me know? There was one for XP that I got from the sweetwater site years ago.

  • Tom

Here’s a good start:
http://www.tweakhound.com/windows7/tweaking/index.html