Struggling with Yamaha THR amp connection to Cubase 12

I’ve made countless guitar recordings on Cubase through the years but recently upgraded to 12 and I’m dying over here. It’s been given too much of a new look and I’m lost trying to do what I’ve done thousands of times.

Shouldn’t my THR amp show in the “devices” drop down box of the Studio Setup? It’s not there but I don’t know why. My computer sees the amp and all is good, it’s connected and working properly. But Cubase doesn’t seem to recognize it.

My backing track plays but not through my headphones connected to the amp, it plays thru the laptop speakers. The guitar plays in my headphones but the Cubase track isn’t recording it.

There’s some disconnect somewhere and I can’t find it. Anyone know what I need to do? I’m sure it’s a simple solution but I’ve tried everything I can think of. Appreciate any help.


Does your amp have an asio driver? If it does can you select it under studio menu (can’t see which submenu as I’m out at the moment)
If you don’t have an asio driver then you will need to get asio4all.

I’m assuming your laptop is windows based.

1 Like

hope this helps :smiley:

So what you are showing me the driver is there? Are you saying it is no longer there? Have you tried reinstalling it. Recently windows did an update on my pc and I had to reinstall the drivers.

If the pictures are the current then I can’t see why it would t work.

1 Like

No mkok. I’m providing the solution to the OP’s problem. That’s why you can’t see anything wrong with the images. I’m not the OP.
It took me so long to do the images I lost the will to live, hence no supporting explanation in my post. I assumed the images would be sufficient. :sunglasses:

1 Like

Oops sorry. For some reason I thought the OP had answered.

I really appreciate you guys trying to help!

Bloodline - Thank you. Those screen shots are exactly what I always saw on my previous Cubase and laptop. In October I simultaneously got a new laptop and upgraded to Cubase 12 and that’s why I’m having so much trouble now.
In the below screenshots hopefully you can see something that’s off. In the first one you can see that Cubase does recognize the THR. But in the drop down box in the other shot the only thing in there is the ASIO item. I really expected to see the THR there but it’s not.

Do these help?
cubase 1

I see asio4all selected in the studio set up window, not YAMAHA’S ASIO THR. Mkok guessed correctly regarding the correct ASIO driver.:sunglasses:
Although I have used asio4all with limited success, I use Yamaha’s asio driver to enable SIMULTANEOUS dry and wet input signals from the THR. Also the Yamaha ASIO driver gives a much louder input signal than asio4all.
Go to the Yamaha web site and download the latest ASIO THR driver. Set it up EXACTLY as I have in both YAMAHA’S THR remote app and cb12. It should then work properly with all features enabled.

1 Like

Ok, I’ll do that.

About a month ago I had briefly gotten a faint guitar recording that had crappy sound quality and got sidetracked before I could really dive into it. So I was assuming the driver was all set. Will download and hopefully resolve this. REALLY appreciate the time you guys are giving!

You guys rock! I’m back in business. It was just the driver.

With THR showing in Cubase I just assumed the amp wasn’t the issue and that Cubase was. Like I said, I’ve simultaneously started on a new laptop and Cubase 12 after 7 years of making dozens of guitar recordings on another laptop and earlier versions of CB. With the new layout of CB it made it difficult to recognize the usual steps I always did.

Thanks again. Marking this thread Solved.